Loan calculation: what gives?

Roberto Leibman roberto at
Thu May 20 13:10:21 EDT 2004

Roberto Leibman wrote:

>I'm trying to set up a loan through the loan druid. Here are the details
>I put in:
>Amount 11331.00
>Interest Rate 4.8%
>Start Date 5/18/2004
>Length: 36 months
>Months Remaining: 36
>The resulting formula seems to be:
>pmt( 0.04800 / 12 : 36 : 11331.00 : 0 : 0 )
>The druid is showing me payments of 39729.60!!!! What gives?
>The same exact formula (ok, changing ; for :) in openoffice gives me the
>correct number of 338.58 that I see in my loan documents and expect. Is
>this a bug? Did I enter any of the information wrong?
>P.S. If I try to enter 3 years instead of 36 months for Length the
>program just hangs (or at least it seems to, I'll let it run a bit
>longer since it does seem to be doing something to the CPU.)
>Thanks for the help,
>P.S. I'm using the version packaged with Fedora Core 1: gnucash-1.8.8-1
>according to rpm -q
>gnucash-user mailing list
>gnucash-user at
OK, I tried compiling a fresh gnucash 1.8.9 from scratch to see if that 
was the problem. No, it still occurs.

Next I tried a completely fresh file, starting off with just a blank 
checking and a blank car loan set of accounts. It still occurs.

Then I tried the exact same thing on my laptop, also running fedora and 
also running gnucash 1.8.8-1 rpm. ... It works!!!! 

I followed the exact same steps on my laptop and my PC: even side to 
side through a ssh shell (the computer with a problem is at home). One 
works and one doesn't. I'm totally clueless about what might be going on.
Any ideas? Anything else to try or test? Could it be one of the 
libraries that gnucash is dependent upon?


More information about the gnucash-user mailing list