One of my reports is missing: Solved

Derrick Ashby daeroncs at
Thu Apr 21 07:43:46 EDT 2005


>>I figured that there was probably something wrong with the
>>installation.  No, I haven't tried to upgrade. I'm running 1.8.11 on
>>gentoo, and I haven't run emerge on the system for a couple of weeks
>>since I haven't yet got around to upgrading to the 2.6 kernel.  I don't
>>think that I deleted the report - there isn't anything in Trash that
>>might be it, and I haven't emptied the Trash for quite a while.  If I
>>had deleted the report, where would I have deleted it from?  I don't
>>mind recreating the report, but I can't do that unless it's in the
>>Reports menu.  How do I get it back in there?
>The Liability Barchart is defined in category-barchart.scm.
>If it's not in your Reports menu, then you're missing that
>report (or if you're in some weird locale you've got a bad
>First, make sure you've got the category-barchart.scm; it'll be in
>/usr/share/guile-modules/gnucash/report/.  If it's not there, that's
>your problem.  If it IS there, then the next thing to look for is the
>translations.  Run in the C locale and see if the report is there.  If
>so, but not in your locale, then it's a translation problem.  If not,
>then I have no idea what's going on.
I found that I had that file. My locale is Australia, which doesn't
strike me as being particularly weird (but then I'm Australian...). In
any case, the file seemed to provide all barcharts in gnucash, and I had
the other three, no problem. Eventually, it occured to me to wonder
whether I might not have saved the liability barchart at some stage, and
found that I had. (I hd wanted two copies of the report - 1 that
included the mortgage account, and one that only included the credit
cards) When I renamed the saved-reports-1.8 file, the Liabilities
barchart turned up in the menu. Remind me not to save another report
definition, will you?

Incidentally, this problem affected every set of accounts I opened, even
though I had saved the report layout in only one. This would seem to be
something of a design problem.


More information about the gnucash-user mailing list