400 Bad Request error when trying to checkout SVN

Derek Atkins warlord at MIT.EDU
Thu Dec 1 18:51:34 EST 2005


Quoting Tor Harald Thorland <linux at strigen.com>:

>> What's your IP Address?  If you tell me I'll look in the logs.
> (That is the ip on my dsl right now. I have a proxy, but
> it is between that one and me. So you should see that ip)

I suspect your proxy is screwing you up.  Here's what I see in the logs:

[root at cvs httpd]# grep error_log
[Thu Dec 01 17:22:48 2005] [error] [client] Could not fetch
resource information.  [301, #0]
[Thu Dec 01 17:22:48 2005] [error] [client] (2)No such file or
directory: Requests for a collection must have a trailing slash on the 
URI. [301, #0]

So, I suspect there's an HTTP proxy between you and the server which
is screwing up the subversion request...

>> Do you have a silent HTTP proxy between you and here?
>> What happens if you try:
>>  svn co https://....
> Worked perfect! got it all downloaded.

... and this would coroborate my guess.  Using https would've bypassed
the proxy server.

> As you can see below, it works everytime i have the https, and whet I
> use http it fails.
> Checked out revision 12076.
> tortho at inspiron:~/svn$ svn checkout
> http://svn.gnucash.org/repo/gnucash/trunk gnucash
> svn: REPORT request failed on '/repo/!svn/bc/12076/gnucash/trunk'
> svn: REPORT of '/repo/!svn/bc/12076/gnucash/trunk': 400 Bad Request
> (http://svn.gnucash.org)
> tortho at inspiron:~/svn$ svn checkout
> https://svn.gnucash.org/repo/gnucash/trunk gnucash
> Checked out revision 12076.
> tortho at inspiron:~/svn$

Hmm..  Are you running "checkout" instead of "update"?  You do realize
that you only need to checkout once and then you can use update from
then on, right?

Anyways, not that https is a bad workaround, but you might want to
look into why your proxy is screwing you over and fix it.  It will
save you lots of heartache down the road.

I'll note that I only see ONE request from you in the logs here
since November 27th, and that's the log message I quoted above from
an hour ago.  So if you've tried the checkout multiple times then
you are DEFINITELY running into a proxy issue!


       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL: http://web.mit.edu/warlord/    PP-ASEL-IA     N1NWH
       warlord at MIT.EDU                        PGP key available

More information about the gnucash-user mailing list