Problems retrieving share prices

Leslie Katz lesliek at
Wed Feb 1 02:53:50 EST 2006

Dale Alspach wrote:

>Did you check the box that says get online quotes and choose a source for
>each of the 33 securities? (Edit Account)
>Dale Alspach
My apologies.

Section of the guide says, "you should run the 
'dump-finance-quote' test program ... to test if Finance::Quote is ... 
working properly".

Well, I did that (or so I thought). I issued the command 
"dump-finance-quote". It worked. I got output telling me the usage and 
available sources.

It's only while trying some more to figure out what was wrong that I 
decided to issue instead the command "dump-finance-quote asx agl".

 From that, I got the following output:

"The query for AGL failed!!
Finance::Quote fields Gnucash uses:
symbol: AGL <=== required
date: ** missing ** <=== required
currency: AUD <=== required
last: 17.960 <=\
nav: <=== one of these
price: 17.960 <=/
timezone: <=== optional"

I'm afraid I'm no better at interpreting that output than I was the 
sentence in the guide.

I can confirm that the AGL query worked in part, because today's closing 
price was in fact $17.96. However, I don't know from what it is that the 
date's missing.

I'd be grateful for any instructions as to how to solve the date problem.

More information about the gnucash-user mailing list