Compiling 1.8.12 on debian
linux at codehelp.co.uk
Sat Feb 4 15:08:12 EST 2006
On Sunday 08 January 2006 11:31 pm, Martin Wolters wrote:
> Summary: Building from scratch on debian
Why are you building 1.8.12 at all when all development is on gnucash-1.9.0
using subversion? GnuCash is a complex build and no-one is developing 1.8.x
> in order to enable HBCI on debian I am trying to install aqbanking and
> gnucash from scratch. I use the following build sequence:
(n.b. if a feature is not available in the Debian package there is usually a
VERY good reason for the omission - i.e. it won't build.)
I don't use HBCI with gnucash but the developers who do are solely working on
gnucash 1.9.0, leading to gnucash2, available via subversion:
> ./configure --disable-error-on-warning
That's one mistake - if you need that option, something is already wrong in
your build environment.
> --build=i686-pc-linux-gnu --prefix=/usr --enable-debug
It's often unwise to build directly into /usr/ - use a prefix in somewhere
safer like /opt/.
> make install
You don't mention sudo so I hope you are NOT trying to build gnucash as
ROOT!!! (Summary: DON'T!)
> --disable-error-on-warning required due to multiple warnings a la:
> 'XXX' differ in signedness
Then you sound like you are using gcc4 along with g-wrap 1.3 - a well known
problem pairing. g-wrap 1.3 cannot produce code compatible with gcc4 and you
must switch to g-wrap 1.9 and all it's attendant libraries.
> ( BTW: How do I figure out which configure options the official debian
> package used? Sorry, I am a Debian-Newbie )
You can (via the package development page) but it's not advisable. Instead,
obtain svn, read the README.svn and use that information - IF you still want
to build from source.
Note that building from svn (or CVS with other projects) is different to
building a distributed tarball. See the README.svn for full information.
> In the mailing list archive people talked about multiple guile-versions
> causing similar things. But I don't see multiple versions on my system.
No, you've just got an old version that needs to be replaced. WHEN you replace
it, you could be left with a mixed system and that's when the multiple
version issue arises. Jump to the solution: purge g-wrap 1.3 and guile.
Install g-wrap 1.9.6-3 from testing or unstable.
> option. I have a feeling that something with the guile setup is wrong.
It is. Your compiler version means you need g-wrap 1.9 which in turn means you
may not be able to build 1.8 anyway. Switch to the subversion gnucash 1.9.0
tree and upgrade g-wrap and guile.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: not available
Url : http://lists.gnucash.org/pipermail/gnucash-user/attachments/20060204/44cf691b/attachment.bin
More information about the gnucash-user