SOLVED! Re: Problem with swedish characters

Derek Atkins warlord at MIT.EDU
Mon Feb 13 09:40:19 EST 2006

This reply should have gone to gnucash-user.  I'm
forwarding it there so others can see and learn
from your problems and solutions.


Fredrik Persson <frepe at> writes:

> Derek, I think you solved my problem!!
> I'm not too good at this thing called "locale". However, it turned out that I had not generated the sv_SE locale that I needed.
> This is what I did to solve the problem:
> First, "locale -a" gave me:
> C
> en_AU.utf8
> en_BW.utf8
> en_CA.utf8
> en_DK.utf8
> en_GB.utf8
> en_HK.utf8
> en_IE.utf8
> en_IN
> en_IN.utf8
> en_NZ.utf8
> en_PH.utf8
> en_SG.utf8
> en_US.utf8
> en_ZA.utf8
> en_ZW.utf8
> ... and at that point, starting gnucash with "LC_ALL=sv_SE gnucash" gave me the screenshots that I posted. However, when I edited /etc/locale.gen and added:
> sv_SE iso-8859-1
> ... and then ran locale-gen, I could start gnucash with "LC_CTYPE=sv_SE gnucash" and have my file opened properly, displaying all characters as they should be displayed.
> I assume this is the encoding I've been using before, when running gnucash. I just hope gnucash 2.0 will properly handle the converting of my old workfile to a new format...
> So, your tip got me in the right direction, thanks!
> /Fredrik

       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL:    PP-ASEL-IA     N1NWH
       warlord at MIT.EDU                        PGP key available

More information about the gnucash-user mailing list