More on gnucash on Intel Mac

David Hampton hampton-gnucash at
Sat Jun 17 15:56:55 EDT 2006

On Sat, 2006-06-17 at 14:19 -0500, Jed Diem wrote:
> I downloaded the 1.9.7 sources and checked the dependencies;  most, if 
> not all, seemed to be satisfied with binary fink downloads.  For some it 
> was not all together clear.  I can provide details. 
> One which I was sure would be satisfied was one for guile 1.6 which is 
> installed (with development package) on the system.   But ./configure 
> aborts with the following message:
> "checking for guile - 1.6.0 <= version < 99.99.99... no:
> configure: WARNING: guile version check failed
> configure: error:
>   guile does not appear to be installed correctly, or is not in the
>   correct version range.  Perhaps you have not installed the guile
>   development packages?  Gnucash requires at least version 1.6 to build."
> Since guile (1.6) was in /sw/bin as guile-1.6, I renamed (moved) it to 
> guile.  Same error message from ./configure.

You'll need the -dev packages for guile and anything else gnucash says
that it needs to compile.  These packages are needed because you're
compiling gnucash, not just running a pre-built executable.


More information about the gnucash-user mailing list