Strange behavior importing QFX files...

Trey Blancher trey at
Wed Sep 24 01:20:24 EDT 2008

I'm using GnuCash 2.2.4, and the initial QFX import into a brand new
GnuCash file works.  Everything in my checking account reconciles
nicely.  The following month, when I go to import this months QFX file
from my bank, GnuCash "misses", for lack of a better term, some key
transactions.  I've examined the raw QFX files, and the transactions
are indeed present, but GnuCash simply does not add them to the
register.  The missed transactions invariably are one of two classes
of transaction:  they're a repeating transaction with the same dollar
amount each month (e.g. my rent, and my student loan are the same
value each month), or they're one of my several small (i.e.
$1-$5/transaction) transfers into my savings account (my bank has a
program where every purchase I make with my check card causes $1 to be
transferred to a high-interest savings account).

I've had this problem for several months if not more than a year
(actually, ever since I started importing from my bank sometime last
year).  I don't know how many versions of GnuCash I've tried, but it
has happened with every one.  I've examined the transaction IDs
(<FITID>) for the previous and current months for the missed
transactions, and as far as I can tell they're different.  Doing a
spot check on my monthly rent, and they only differ by one digit, but
they are different (2008070101 for one, and 2008080101 for the
second), so I don't see why GnuCash should skip them.  I'm willing to
supply my QFX files demonstrating the behavior, if someone can point
me to a good QFX file format reference so I can properly sanitize
them.  I think I also tried OFX files, and got the same behavior.

Any help would be appreciated.


Trey Blancher

More information about the gnucash-user mailing list