Online Banking and Tiger 10.4.11

Andre Powell apowell656 at
Tue Sep 30 12:32:04 EDT 2008

On 9/30/08 12:22 PM, "David Reiser" <dbreiser at> wrote:

> On Sep 30, 2008, at 12:08 PM, David Reiser wrote:
>> On Sep 30, 2008, at 10:41 AM, Andre Powell wrote:
>>> [...]
>>> I have used APPID ³Money² and APPVER ³1700² and not used it and it
>>> still
>>> does not work , the only way that I am able to get the data is via
>>> the
>>> script. It would really be great to get this to work.
>>> Andre
>> This is definitely an aqbanking issue rather than a gnucash issue. But
>> anyway...
>> Which version of gnucash? A couple days ago I updated the fink
>> repository to gnucash 2.2.7 and with it switched to aqbanking 3
>> (library name aqbanking20). My tests show that the newer aqbanking
>> works as well as the older one now for OFXDirectConnect, so I updated
>> for the German users that need a newer HCBI. It's possible there are
>> differences among bank's implementation of OFX, however. One
>> possibility is that the bank doesn't allow "get Accounts" queries. In
>> that case you'd have to set up your aqbanking account manually (in
>> addition to setting up the user).
>> APPVER "1700" would match with and APPID "QWIN" not "Money" (I think
>> Money's version numbering scheme is lower than Quicken's). If
>> downloading with works, then you should be able to use the same
>> APPID and APPVER that is passing.
> Silly me. According to the ofxblog, both Money Plus and Quicken 2008
> have the same APPVER "1700".
> Still, if works with a lower appver, I'd use that. We're at a
> point where the banking industry is being forced to pretend they are
> using multifactor authentication. The newer versions of Quicken, at
> least, implement that as the client having to produce a uid. If you
> tell the bank you have the newest version, the server may be expecting
> you to supply a uid as well as password and userid. Aqbanking doesn't
> implement that yet because there hasn't been enough information
> published about how it really works (even though the ofx spec does
> include information on the subject). If you tell the bank you're using
> an older version, it's conceivable that the server will still allow
> access under the old rules. I don't know how much longer that will
> last, though.
> I could be way over-analyzing the situation. :)
>> If you set AQOFX_LOG_COMM=1 in your environment ('export
>> AQOFX_LOG_COMM=1' for bash), than /tmp/ofx.log contains a transcript
>> of the ofx communication session from aqbanking. It appends session
>> logs until you reboot, so if you try multiple times, the most recent
>> attempt is at the bottom of the file. Don't leave that variable set in
>> your environment, though, because your ID and password appear in the
>> data stream as plain text. It doesn't leave your computer that way
>> because it isn't sent until an SSH session is established, but the log
>> is constructed outside ssh. On a mac, /tmp is a symlink to /private/
>> tmp. The ofx.log file will at least let you see if you get an error
>> message from the bank's ofx server vs. some more general communication
>> failure.
>> Dave
>> --
>> David Reiser
>> dbreiser at
>> _______________________________________________
>> gnucash-user mailing list
>> gnucash-user at
>> -----
>> Please remember to CC this list on all your replies.
>> You can do this by using Reply-To-List or Reply-All.
> --
> David Reiser
> dbreiser at
I entered everything manually and still get the same error types or no
result. With aqbanking I do have the latest version from fink flagged
status    name    installed    version    binary    category    summary
NO         aqbanking20         3.7.2-1    3.7.2-1    crypto    Online
banking interface  

I am going to run a selfupdate to see if this will lead to some type of fix,
but as I stated before it works with the script.

More information about the gnucash-user mailing list