System error when trying to obtain stock quotes

AmigaPhil AmigaPhil at
Tue Nov 17 12:29:28 EST 2009

Gérard TESTA wrote:

>> I think you have messed-up your F::Q installation.
>> gnc-fq-update is not a good idea under Linux (IMHO) because
>> Perl can be installed differently depending on your Linux
>> distribution.
>> I suggest to re-install Finance::Quote from your distribution
>> provider.  (If you can get F::Q 1.17, that's good, because it
>> contains a fix for the online retrieval of currency quotes.)
>> Then, try gnc-fq-dump, at least to check that Finance::Quote
>> can be found and used by GnuCash.
>> From your email, I guess you are from France (?)
>> Did you use 'lerevenu' as one of the source for quotes ?
> I re-install F::Q 1.17 from Ubuntu
> Then I tried gnc-fq-dum :
> gerard at gerard-desktop:~$ gnc-fq-dump yahoo  AMZN
> Finance::Quote fields Gnucash uses:
>    symbol: AMZN                 <=== required
>    date: 11/16/2009           <=== required
>    currency: USD                  <=== required
>    last: 131.59               <=\
>    nav:                      <=== one of these
>    price: 131.59               <=/
>    timezone:                      <=== optional

Good !

> But I always have the same error message "Erreur système"
> and in the terminal Error: could not flush file-descriptor 26
> You guess right, I am from France.
> I use Boursorama, Lerevenu, Yahoo Europe all at the same time, nothing
> works.

Ha, I'm almost sure the problem is due to lerevenu, because I had
the same issue some times ago. has changed its web site, making the module to crash, and thus the whole online retrieval process
to fail.

The author of sent me a new version of the module
which is not yet available from F::Q GIT.
I have uploaded it here:

As root, replace your '' by this one (if needed,
change the permission of the file to root/root and read-only).


More information about the gnucash-user mailing list