Please Help!!!! Cannot open my gnucash file!

JP Briggs jp.briggs at
Mon Nov 23 11:37:09 EST 2009

Well I'm back up and running. My thoughts are that the upgraded version
somehow overwrote my data file with this gconf referencing file when I tried
to load the data file in Gnucash. This was a repeatable problem, since I'm
running on a virtual machine, I could roll back to my previous Ubuntu
version. Once rolled back, if I tried to open the data file (shared folder
on my host machine, so it wasn't rolled back) I would get the same Unable to
parse XML file. So it appears that the upgraded version was overwriting my
data file.

What I've done to finally fix it, is to install a fresh copy of Ubuntu 9.10
on a new guest VBox machine, install Gnucash, and then open the data file
from the shared folder. Now it opens just fine. Seems like it was some kind
of bug in the upgrade process.

I'd be interested to hear if anyone else experienced problems with



On Mon, Nov 23, 2009 at 11:33 AM, Derek Atkins <warlord at> wrote:

> JP Briggs <jp.briggs at> writes:
> [snip]
> >     > Found Finance::Quote version 1.16
> >     > /home/jp/Documents/gnucash/JPandRobyn:2: element gconf: Schemas
> validity
> >     > error : Element 'gconf': No matching global declaration available
> for
> >     the
> [snip]
> > jp at Macbuntu:~/Documents/gnucash$ cat JPandRobyn | head
> > <?xml version="1.0"?>
> > <gconf>
> >     <entry name="file0" mtime="1258650368" type="string">
> >         <stringvalue>/home/jp/Documents/gnucash/JPandRobyn</stringvalue>
> >     </entry>
> > </gconf>
> > <?xml version="1.0"?>
> > <gconf>
> >     <entry name="sort_order" mtime="1256567967" type="string">
> >         <stringvalue>ascending</stringvalue>
> This isn't a GnuCash data file.  This looks like a GConf data file.  So
> this begs the question of what's going on, but it sounds like it might
> an Ubuntu 9.10 bug.
> What happens if you move your data file somewhere else?  I.e., instead
> of putting it into ~/Documents, saving your data file somewhere like
> ~/GnuCash-Files or some other new directory?
> > -JP
> -derek
> PS: Sorry I didn't respond to this earlier, I was offline all weekend
> and I'm just finally getting back to my email.
> --
>        Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
>       Member, MIT Student Information Processing Board  (SIPB)
>       URL:    PP-ASEL-IA     N1NWH
>       warlord at MIT.EDU                        PGP key available

More information about the gnucash-user mailing list