Mac upgrade, "There was an error parsing the file ..."

David Dannemiller DPDannemiller at
Thu Jun 17 00:53:25 EDT 2010

On Jun 14, 2010, at 8:46 AM, Derrick Hudson wrote:
> "David Dannemiller" <DPDannemiller at> wrote:
>> I downloaded Ubuntu 6.10 Desktop, and installed it under Fusion.  GNUCash is not part of the default installation.  I tried to install it using both "Add/Remove..." and "Synaptic Package Manager" but was unsuccessful - messages like "Could not download all repository indexes."  Canonical no longer supports 6.10, so maybe they removed the repositories.
> The repositories for EOL releases are no longer on the primary mirrors.  Instead, change your /etc/apt/sources.list to use "" as the server.
> -Derrick

To review:  I'm starting with an old Mac running GC 1.8.11 (obtained through Fink).  I bought a new Mac and downloaded 2.2.9, but it would not read the old file format ("There was an error parsing the file ...").  One suggestion from the list was to pass the file through GC 2.0.x.  Ubuntu 6.10 was suggested as a way to access GC 2.0.x.

Derrick's suggestion on changing sources.list worked.  Ubuntu 6.10 has GC 2.0.1.  GC 2.0.1 successfully read the old file format.  I browsed accounts, saved the file, exited, and re-opened.  Everything looked promising.  I transferred the file to the new Mac, and successfully opened it with GC 2.2.9.  I browsed, saved, and exited.  I tried to re-open the file, but received the error message "There was an error parsing the file ..."

I thought I might have done something wrong, so went back to my old Mac to start again, Mac-1.8.11_to_Ubuntu-2.0.1_to_Mac-2.2.9.  Same result - everything worked until I opened the file for the second time under 2.2.9 on the Mac.  One other observation - The original GC data file size on my old Mac is 9.5 Mb.  After conversion on Ubuntu it is 885 Kb - an order of magnitude smaller.  Does this make sense?

To see if the problem might be caused by the Mac version of 2.2.9, I targeted GC 2.2.9 on Ubuntu 10.04 as the final destination.  In other words, Mac-1.8.11_to_Ubuntu-2.0.1_to_Ubuntu-2.2.9.  Same problem - everything worked until I opened the file for the second time under 2.2.9 on Ubuntu.

I'm stumped.

David Dannemiller

More information about the gnucash-user mailing list