Windows 10 Crash when running Any Report (GnuCash 2.6.14)

David T. sunfish62 at
Thu Oct 27 06:44:35 EDT 2016

Never mind.  I can't read any more. 
  On Thu, Oct 27, 2016 at 0:11, Guy Subscriber<subscriber.guy.1 at> wrote:   Hello

When I run any report in GnuCash currently, GnuCash crashes before
showing any report.

This happens for any GnuCash file, even a newly created default one.

Using the ledger or anything else still works. It seems only the
reports have a problem.

This happens since I upgraded to GnuCash 2.6.14. But even after
downgrading back to 2.6.12 - which I was using succesfully - the
crashes persist. Perhaps of interest, I upgraded using Chocolatey. But
afterwards removed everything and installed manually with the
installer from the GnuCash website. The result was the same. I tried
older versions too, but it did not make any difference.

It also happens when I run GnuCash as Administrator. I though it
might've been a file access issue.

It must be something local to my machine, because I didn't immediatly
find any similar reports.

The error in the Windows Event Log is:

Faulting application name: gnucash.exe, version:, time stamp: 0x5771b473
Faulting module name: libcairo-2.dll, version:, time stamp: 0x545551f2
Exception code: 0xc0000005
Fault offset: 0x0003a988
Faulting process id: 0x1b20
Faulting application start time: 0x01d22fb781517510
Faulting application path: C:\Program Files (x86)\gnucash\bin\gnucash.exe
Faulting module path: C:\Program Files (x86)\gnucash\bin\libcairo-2.dll
Report Id: 8903721f-3ac5-4cf7-a3c5-086f7f4efea5
Faulting package full name:
Faulting package-relative application ID:

The Exception Code is a general "Access Violation" I believe.

Here are some details of my System if that's relevant:

OS Name Microsoft Windows 10 Home
Version 10.0.14393 Build 14393
System Manufacturer Dell Inc.
System Model Inspiron 7559
System Type x64-based PC
Processor Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz, 2601 Mhz, 4
Core(s), 8 Logical Processor(s)
BIOS Version/Date Dell Inc. 1.1.8, 17/04/2016

I'm on the latest Windows 10 Updates. It could be related to a recent
Windows Update, but I do not know how to confirm this.

I used "Process Monitor" to see what the application is up to right
before the crash. I can see it writing the report to a temporary
When I open the HTML file, I actually see the report.
Afterwards, the only notable thing I see is an attempted access to a
registry key "HKLM\System\CurrentControlSet\Control\Session
Manager\ResourcePolicies" which fails with "NAME_NOT_FOUND", but I'm
not sure if that matters.

Can anyone point me in a direction to investigate the problem further?
I would love to get the reports working again.

If I'm talking in the wrong please, I do apologize.

Many Thanks
gnucash-user mailing list
gnucash-user at
Please remember to CC this list on all your replies.
You can do this by using Reply-To-List or Reply-All.

More information about the gnucash-user mailing list