[GNC] v3.8

John Ralls jralls at ceridwen.us
Tue Dec 31 12:59:46 EST 2019

> On Dec 31, 2019, at 9:57 AM, boldstripe <michael.nabble at wengam.com> wrote:
> I may have posted too soon without testing the debian packages for v3.8.
> Installation from the v3.8 .deb files I gave the URL for failed for me on
> Debian Buster when installing using apt (and individually using gdebi, with
> similar dependency issues). I uninstalled v3.7 first.
> Here is a transcript from my Terminal session:
> michael at thinkpad-debian:~/Downloads$ cd gnucash_3.8_deb/
> michael at thinkpad-debian:~/Downloads/gnucash_3.8_deb$ sudo apt install
> ./*3.8*.deb
> Reading package lists... Done
> Building dependency tree       
> Reading state information... Done
> Note, selecting 'gnucash' instead of './gnucash_3.8b-1_amd64.deb'
> Note, selecting 'gnucash-common' instead of
> './gnucash-common_3.8b-1_all.deb'
> Note, selecting 'python3-gnucash' instead of
> './python3-gnucash_3.8b-1_amd64.deb'
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies:
> gnucash : Depends: libaqbanking43 (>= 5.99.43) but it is not installable
>           Depends: libboost-regex1.67.0-icu63 but it is not installable
>           Depends: libgwengui-gtk3-0 (>= 4.99.24) but 4.20.0-9 is to be
> installed
>           Depends: libgwenhywfar78 (>= 4.99.10beta) but it is not
> installable
>           Depends: libstdc++6 (>= 9) but 8.3.0-6 is to be installed
>           Recommends: gnucash-docs but it is not going to be installed
> E: Unable to correct problems, you have held broken packages.

As a guess, Dmitry built it for testing or unstable rather than stable.

John Ralls

More information about the gnucash-user mailing list