Jason Rennie
Sat, 15 Jul 2000 11:16:56 -0400


I just finished doing an install of 1.4.2 on RedHat 6.2.  I'd like to
share my experiences so that the install process and documentation can be

So, the first thing that bit me was the gtk-xmhtml/gtk-xmhtml.h
requirement.  I had no idea where to get this and I was not able to locate
a package that had this file.  Eventually, I tried installing HelixCode
Gnome (even though I already had RedHat Gnome).  This change allowed
configure to pass that test.  Is the RedHat 6.2 Gnome package different
from the HelixCode package?  Does anyone know why HelixCode would have
this header file, but RH 6.2 wouldn't?  Btw, my RH 6.2 was installed as a
"Gnome workstation".

I also hit a bump with g-wrap.  G-wrap wasn't listed in the dependencies,
but I was able to find it easily at  When I tried to install
the RPM, though, it complained of a guile-devel dependency.  I installed 
both packages w/o a hitch once I got the RPMs, but it'd be nice
to note these dependencies in the documentation.

The last problem that I ran into was with readline and termcap libraries.
RH 6.2 comes with shared libraries ( and,
but during gnucash compilation, compilation of src/.libs/gnucash uses
"-lreadline" and "-ltermcap", which (if I'm not mistaken) causes ld to
only look for static libraries (libfoo.a).  A little detective work
brought me to the conclusion that these options come from "guild-config
link", which produces:

  -L/usr/lib -lguile -ldl -lreadline -ltermcap -lm

I fixed this by changing GUILE_LINK_ARGS in to be:

  -L/usr/lib -lguile -ldl /usr/lib/ /lib/ -lm

I guess this is really a RedHat issue, but it certainly affects gnucash.
Should the guild-config program be outputting shared object file names
rather than -l link commands?  I can see why RedHat would want to only be
distributing shared object libraries...

Anyway, after going through all that, GNUCash compiled for me.  Yeah!  
Now I have to see about converting my finances over so that I can 
actually use the damn thing... :-}

Jason D Rennie
MIT:  (617) 253-5339
MITRE: (781) 271-7249