Dependancy problems on the latest unstable version

Richard -Gilligan- Uschold
Tue, 03 Oct 2000 14:01:01 +0000

I'm trying to build the latest unstable version of gnucash, so I can
make a patch to submit a new report, which I developed against 1.4.4  I
have successfully made the patch against v 1.4.4.

First, a minor problem in the README.  I downloaded gnucash-1.5.2.tar.gz
and the README has the following command that fails:

cvs -z3 -Pd checkout
-rHEAD gnucash
cvs: invalid option -- P

The following works correctly:

cvs -z3 -d checkout -P -rHEAD gnucash

After resolving numerous missing dependencies (it supprised me how many
there were since 1.4.4), I've come across one I can't figure out.

Unknown library `gtkhtml'
checking for gtk_html_new in -lgtkhtml... no
configure: error: Cannot find gtkhtml.  See the README for more info.

I have installed gtkhtml-devel-0.6.1-1mdk.i586.rpm and

I tried:
./configure --with-gnome-libs=/usr/lib
Same error.

It was not clear in which directory configure was looking for gtkhtml,
so I added an echo statement to configure.

which gave:

GTKHTML_LIBS=-rdynamic -L/usr/lib -L/usr/X11R6/lib -lgtkhtml
-lgdk_pixbuf -ltiff -ljpeg -lpng -lgnomeprint -lgnomeui -lart_lgpl
-lgdk_imlib -lSM -lICE -lgtk -lgdk -lgmodule -lXi -lXext -lX11 -lgnome
-lgnomesupport -lesd -laudiofile -lm -ldb1 -lglib -ldl -lxml -lz
-lpspell -lstdc++

Well, in /usr/lib I have:
18 pluto /usr/lib> ls /usr/lib/libgtkhtm*
/usr/lib/libgtkhtml.a    /usr/lib/
/usr/lib/*  /usr/lib/*

11 pluto /usr/lib> grep gtk_html_new libgtkh*
Binary file libgtkhtml.a matches
Binary file matches
Binary file matches
Binary file matches

By the way, I'm running Mandrake 7.0 on a PIII 533


Gilligan            |                    __o           .oooO
                   /|                  _ \<,_          (   )
                  /p|\                (_)/ (_)          \ (   Oooo.
                 /  | \             ------------         \_)  (   )
                ========                                       ) /
                 ========           (_/