Dependancy problems on the latest unstable version

Dave Peticolas
Tue, 03 Oct 2000 14:57:02 -0700

Richard -Gilligan- Uschold writes:
> I'm trying to build the latest unstable version of gnucash, so I can
> make a patch to submit a new report, which I developed against 1.4.4  I
> have successfully made the patch against v 1.4.4.
> First, a minor problem in the README.  I downloaded gnucash-1.5.2.tar.gz
> and the README has the following command that fails:
> cvs -z3 -Pd checkout
> -rHEAD gnucash
> cvs: invalid option -- P
> The following works correctly:
> cvs -z3 -d checkout -P -rHEAD 
> gnucash
> After resolving numerous missing dependencies (it supprised me how many
> there were since 1.4.4), I've come across one I can't figure out.
> ./configure
> ...
> Unknown library `gtkhtml'
> checking for gtk_html_new in -lgtkhtml... no
> configure: error: Cannot find gtkhtml.  See the README for more info.
> I have installed gtkhtml-devel-0.6.1-1mdk.i586.rpm and
> gtkhtml-0.6.1-0mdk_helix_1.i586.rpm
> I tried:
> ./configure --with-gnome-libs=/usr/lib
> Same error.

If you installed gtkhtml after your first try with configure, then
delete config.cache before you run it again.