Something is still broken with the build process

Derek Atkins warlord at MIT.EDU
Fri Apr 4 18:29:25 CST 2003

Laurent Duperval <lduperval at> writes:

> On  4 Apr, Derek Atkins wrote:
> > That's what I thought.   This is _WRONG_.
> > 
> No it's not. Every piece of software I compile is compiled and installed
> like this and they all work. Doing this allows you to do soft-linking in
> any directory and it will alway work.

WTF is "soft linking"?

And yes, it is wrong.  "gnucash" is not "every piece of software".
I'm trying to tell you what you need to do with GnuCash.  It doesn't
matter if lots of other stuff works differently, this is how GnuCash
works.  Jumping up and down and ignoring the directions you are given
because you think it should work differently is not the way to convince
people it's broken.

Basically, if you're not going to follow directions, then maybe you
can go find someone else to hand-hold you.  I'm trying to help.  Don't
ignore what I'm saying.

> > You should run:
> > 
> >         ./ --prefix=/usr/local/soft/gnucash/run/i686_pc_linux
> > 
> That's what I used to do but this breaks soft-linking. When I complained
> about this (for other applications), I was told that when using
> autoconf, you should use the --prefix when running make install, not
> when running configure (or autogen in this case), if you plan on doing
> softlinking.

As I said, I don't know what "soft-linking" is in terms of software
installation.  Basically, gnucash needs to know where it's going to be
installed when you configure it.  Period.  End of story.  You have to
tell it during the configuration phase.  You cannot change it during
the installation phase.

If you want to install into a temporary directory, like how .deb or
.rpm is built, you need to use the LIBRARY_PATH environment variable
when you "make install" in order to get the re-link process to work
properly.  You need to do:


env LIBRARY_PATH=$(DESTDIR)$(prefix)/lib:$(DESTDIR)$(prefix)/lib/gnucash \
        make install DESTDIR=$(DESTDIR)

> I will also note that this used to work but then, sometime in the life
> of the 1.7.x series, it suddenly broke. I'd also mentioned it at the
> time.

AFAIK this _never_ worked..  It certainly never worked for me.  This
is how it works now....

Part of the broken is the version of libtool we're using.  I do
not expect this to be changed in the 1.8 series, but hopefully
we can "fix" this for 2.0 (or 1.10).


       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL:    PP-ASEL-IA     N1NWH
       warlord at MIT.EDU                        PGP key available

More information about the gnucash-devel mailing list