problem with my overrides directory

Olaf Faaland ofaaland at
Sun Apr 6 23:18:10 CDT 2003


Anything wrong with the way I'm running autogen, make, and make install?  The 
path setting in the gnucash shell script is wrong.

I run autogen, etc...

olaf> ./ --prefix=/opt/gnucash-unstable --enable-doxygen 
--disable-nls --with-g-wrap-prefix=/opt/g-wrap-1.3.4/ && make && make install

When I run this everything appears to compile and install without errors.  
However, when running gnucash, it fails:

olaf> /opt/gnucash-unstable/bin/gnucash
/opt/gnucash-unstable/bin/gnucash: exec: gnucash: not found

/opt/gnucash-unstable/bin/gnucash contains:

export PATH


exec "gnucash" "$@"

On my system, the real overrides path is

Note that there's an extra 'gnucash' in there.  Modifying the shell script to 
set the path this way seems to work fine.

./src/bin/ seems to set the override directory this way, and I 
don't understand how it could ever work; but the build tools are pretty 
mysterous to me anyway.


More information about the gnucash-devel mailing list