libtool: link: only absolute run-paths are allowed

Gansser, Martin MGansser at
Mon Feb 17 11:12:01 CST 2003

> -----Original Message-----
> From: David Hampton [mailto:hampton at]
> Sent: Thursday, February 13, 2003 6:51 PM
> To: Gansser, Martin
> Cc: gnucash-devel at
> Subject: Re: libtool: link: only absolute run-paths are allowed
> On Thu, 2003-02-13 at 06:39, Gansser, Martin wrote:
> > Hi,
> > 
> > I tried to compile gnucash-1.8.1 on hpux 11.00, but I get 
> the following error message:
> > 
> > ...
> > libtool: link: only absolute run-paths are allowed
> This vaguely rings a bell as an hpux issue that libtool couldn't work
> around.  I don't think its a gnucash issue at all.  I'm not 
> sure what to
> suggest other than skipping the 'make' step and going 
> straight to 'make
> install'.  IIRC, in the former command libtool tries to set up the
> application so it can be run from the source directory, thus relative
> run-paths. In the latter, libtool links the libs for their ultimate
> destination in the file system using absolute run paths.


I solved this problem by removing the test directory from SUBDIRS in the src/gnc-module/,
and the compilation went well, until the start problem.

prounix_root:/opt/gnucash/bin # ./gnucash
/usr/lib/ Unresolved symbol: __moddi3 (code)  from /opt/gnucash/lib/gnucash/
IOT Abfrage (Hauptspeicherauszug ausgegeben)

any suggestions

thanks Martin

More information about the gnucash-devel mailing list