Problems running 1.8.1 under FreeBSD stable

Robert Crowe bob at
Sat Feb 22 11:09:35 CST 2003

Hi, I've been running gnucash for a few years now on FreeBSD with great 
success. Recently I upgraded to 1.8.1 (though the FreeBSD ports system) 
and while the build worked ok, the result seems to have some serious 
problems.  I have a fair amount of programming experience, but very 
little with gnome/gtk and I'm hoping someone might be able to point me 
in the right direction.

Here's what happens:

When I start gnucash, i get the following:

;;; The module name (ice-9 and-let*) is deprecated.
;;; Use (ice-9 and-let-star) instead.

This in and of itself doesn't seem to be a big deal, but might be an 
indicator (I thought perhaps I had an outdated slib or guile, but I 
re-built them from latest ports and installed and get the same thing now).

However, the big problem seems to happen when I try to open any register 
window. I get lots of lines like the following on stderr:

** WARNING **: could not find signal handler 'gnc_register_edit_cb'.

** WARNING **: could not find signal handler 'gnc_register_statusbar_cb'.

** WARNING **: could not find signal handler 'gnc_register_stock_split_cb'.

.... Lots of these types of lines, followed by:

Gtk-WARNING **: gtk_signal_handler_block_by_data(): could not find 
handler containing data (0x8A8E800)

Gtk-WARNING **: gtk_signal_handler_unblock_by_data(): could not find 
blocked handler containing data (0x8A8E800)

Gtk-WARNING **: gtk_signal_handler_block_by_data(): could not find 
handler containing data (0x8A8E800)

.... Lots of these types of lines too.

I assume the two types of errors here are essentially the same thing 
being reported at two different levels.

The register shows up, but it is missing most of it's functionality: 
Visually it looks fine, but I can't sort, I can't split (I can click on 
the split button, but nothing happens to the register window).  One odd 
thing is that if I use the 'close' menu option, nothing happens, but if 
I use the close button, it does close the register.  Also, the transfer 
button seems to work OK (at least it pops up the transfer dialog).  I'm 
guessing that some of the functions may be routed to scheme through a 
callback mechanism and others are directly linked in, but thats just a 

Anyone have any idea of either a solution, or which things I should look 
at to try to narrow this down. I have tried to re-build most of the 
dependencies of this port (it's hard to spot them all however) but so 
far nothing is working.  I'm getting desperate here as I have all my 
finances for the past 2 years in gnucash and have really built a 
reliance on it.  Unfortunately, it's difficult to rollback to the 
previous version for me (I was using 1.6.something) but I guess I'll do 
that as a last result.

Thanks in advance,

Bob Crowe

More information about the gnucash-devel mailing list