HBCI, one transaction does not work

Christian Stimming stimming at tuhh.de
Wed Mar 26 11:01:14 CST 2003

Christian Hoenig schrieb:
>>>I have a gnucash 1.8.2 setup, which works almost perfectly with
>>>hbci/libchipcard. But today when I wanted to initiate a transaction, I
>>>had a big problem.
>>>As I hit "Execute Now" the window simply disappeared and nothing happend.
>>>For testing purpose I initiated another transaction (to somebody else)
>>>and that worked without problem. Then I tried the first transaction
>>>again, and got the same behavior.
>>Did you get any console output (error messages), if you start gnucash
>>from a text console? If yes, which ones?
> Jetzt hab ichs nochmal gemacht, und bekomme folgende Ausgabe:
> 	dialog-hbcitrans: Oops, value is zero. Cancelling HBCI job.
>>Also, I would need the complete transaction data to reproduce your
>>problem. Maybe you can send that privately to me.
> ...
> Amount: 4,94
> ...

I guess you're running gnucash with locale LANG=C (i.e. english 
messages), in which case the decimal point has to be '.' (a point) 
instead of the comma ','. The comma ',' is expected for example in the 
locale LANG=de_DE.

If you enter a comma even though the locale expects a point or vice 
versa, the whole amount is interpreted as zero. And for an amount of 
zero the HBCI code rather aborts the whole transaction (which is 
probably the best thing to do in this case). Maybe I should add a big 
error message dialog if this occurs...


More information about the gnucash-devel mailing list