QOF iteration and callbacks

Linas Vepstas linas at linas.org
Sun Jun 20 17:29:15 EDT 2004

On Sun, Jun 20, 2004 at 02:20:17PM -0400, Derek Atkins was heard to remark:
>  But I see no reason not to combine them..
> Unless there is a strong reason why queriable objects and 'storable'
> objects need to be (or should be) different.


> >> So what's your conceptual distinction between a QofObject and a
> >> QofClass?
> >
> > I dunno.  Something that only knows about parameters vs. something that
> > knows about lots of other things as well.   Maybe 'class' should  be
> > a base-class for 'object'.  Better names for these things might help 
> > too ... 
> True.  I was sort of thinking in terms of "g_object" (or gtk_object)..
> Which sort of makes some basic level of sense to me..  *shrugs*

Is this an explicit statement of support for g_objects?  In the past,
you've seemed allergic to them, and so we've developed this system thats
sort of similar and sort of different.   Should the qof guts slowly
migrate to be tightly integrated to g_objects?  Or maintain a loose
affiliation?  I certainly have the urge to start using the same 
naming conventions where possible.

(Working on qof has helped me get a grip on where they're similar and
where they're different, and I've enjoyed that...)


pub  1024D/01045933 2001-02-01 Linas Vepstas (Labas!) <linas at linas.org>
PGP Key fingerprint = 8305 2521 6000 0B5E 8984  3F54 64A9 9A82 0104 5933

More information about the gnucash-devel mailing list