QOF iteration and callbacks
warlord at MIT.EDU
Sun Jun 20 14:20:17 EDT 2004
linas at linas.org (Linas Vepstas) writes:
> Well, you're the guy who made this distinction when you wrote
> the code way back when ... :)
> -- object defines the relationship to the 'backend'.
> -- class defines parameters.
I had no QofClass, only QofObject... "Class" (and "Instance"
were added by you ;)
> historically, parameters could only be queried, and 'class' was used
> only by the query subsystem. The objects were used only for the
> backend interaction.
I think this is reversed... But I see no reason not to combine them..
Unless there is a strong reason why queriable objects and 'storable'
objects need to be (or should be) different.
>> So what's your conceptual distinction between a QofObject and a
> I dunno. Something that only knows about parameters vs. something that
> knows about lots of other things as well. Maybe 'class' should be
> a base-class for 'object'. Better names for these things might help
> too ...
True. I was sort of thinking in terms of "g_object" (or gtk_object)..
Which sort of makes some basic level of sense to me.. *shrugs*
Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
Member, MIT Student Information Processing Board (SIPB)
URL: http://web.mit.edu/warlord/ PP-ASEL-IA N1NWH
warlord at MIT.EDU PGP key available
More information about the gnucash-devel