FAILURE xaccResolveFilePath test-resolve-file-path.c:81

Michael SEYMOUR michael.seymour at
Mon Sep 25 13:08:24 EDT 2006

Le Lundi 25 Septembre 2006 14:15, Derek Atkins a écrit :
> Michael SEYMOUR <michael.seymour at> writes:
> > Le Dimanche 24 Septembre 2006 20:26, Derek Atkins a écrit :
> >> did you --enable-sql when you configured?
> >
> > No.  I did:
> > sudo ./configure
> > sudo make
> > sudo make check
> > sudo checkinstall
> Um... Why are you using sudo to build all this?  This seems completely
> unnecessary, and it's clearly what's causing your problems.  You
> might try:
> ./configure
> make
> make check
> sudo checkinstall

I agree; this is what I would normally do. However, when I ran ./configure
after doing  'sudo make uninstall' and 'sudo make distclean', I got this funny
error about SLIB not being installed when clearly it was. I tried 
symlinking "ln -s" as specified in one of the posts to a forum and various 
other things (verifying the install by comparing to jsled's configuration 
output, etc) and nothing worked except to run as superuser (sudo). I might 
have borked a part of the install of gwrap or guile or slib but I don't think 

> But you should also keep in mind that there have been reports that
> checkinstall doesn't work properly.  YMMV.

Thanks for the tip. I've recently switched to Ubuntu and checkinstall seems to
be what is recommended. It seems to work (at least I can use gnucash again). 
However, I didn't enter any dependencies into the system so, other than being 
to use dpkg -r gnucash, I'm not  certain what I gained. 



More information about the gnucash-devel mailing list