r15549 - gnucash/trunk/lib/glib28 - Remove lib/glib28/gwin32-2.8.[ch] again.

"Andreas Köhler" andi5.py at gmx.net
Sat Feb 10 22:11:54 EST 2007


David Hampton <gnucash at love2code.net> wrote:
> On Sat, 2007-02-10 at 08:15 -0500, Andreas Köhler wrote:
> > We depend on GLib >= 2.8 on Windows in configure.in, so there is no
> > reason to include unused GLib 2.8 Windows-specific code. Oops. OTOH,
> > gstdio-2.8.h is needed on Unix.
> If we're going to require glib 2.8 to build on windows, then we should
> require glib 2.8 across the board.  Having different levels of system
> libraries depending on the platform being used sounds like a sure way to
> confuse end users.  Glib 2.8 was released 18 months ago on August 12th
> 2005.

A few weeks ago we agreed on GLib 2.6 & friends as our basic dependencies
and I think that is just fine.  On Windows, we totally control what version
is used to build GnuCash, the configure check for GLib 2.8 gives a
definite signal that anything older is unsupported.  I have got the
feeling, that "newer is better" fully applies here.  Nonetheless, I am
pretty sure that end users will not care what we depend on, as long as the
setup.exe works.  Unix users are simply unaffected.
> David

-- andi5

PS: You still want GLib 2.8, do not you? ;-)  Another alternative is to
go back to GLib 2.6 on Windows too.  While actually building against
GLib 2.12, BTW.

"Feel free" - 10 GB Mailbox, 100 FreeSMS/Monat ...
Jetzt GMX TopMail testen: www.gmx.net/de/go/mailfooter/topmail-out

More information about the gnucash-devel mailing list