Raise dependency versions of GLib, Pango and GTK+

Andreas Köhler andi5.py at gmx.net
Tue Jan 16 06:58:20 EST 2007


currently the code base depends on GLib >= 2.4, Pango >= 1.6 and GTK+ >=
2.4. I would like to propose higher base versions, at least for GLib,
better for all three of them.

      * GLib 2.6.0, Pango 1.8.0 and GTK+ 2.6.0 were released in December
        2004. All major distributions should be able to have these
        packages at the time GnuCash 2.2 will be out. RHEL 5 seems to be
        planned for the end of February.

      * We include gkeyfile and gutils from GLib 2.6 already and would
        need to add more if we want to release GnuCash on a Windows

      * We have some GTK+ 2.6 #ifdef's lying around to let users with
        more recent versions take advantage of it. Seems to concern
        mostly GtkComboBox, but not only.

      * Strictly speaking GLib 2.6 would be enough for me, but as
        mentioned above, GLib 2.6, Pango 1.8 and GTK+ 2.6 were released
        around the same time, so they might interplay better than other
        version combinations.

There might be other reasons, like removing the burden to check whether
a GLib/Gtk 2.6 feature is worth single-casing it. What do you think?

-- andi5

PS: Pango seems to be an implicit dependency, so maybe no code change is
necessary here. One might then also consider an update of LibGSF or
GOffice, but that is not overly important for me.

More information about the gnucash-devel mailing list