Raise dependency versions of GLib, Pango and GTK+

David Hampton hampton-gnucash at rainbolthampton.net
Fri Jan 19 10:15:26 EST 2007

On Wed, 2007-01-17 at 20:42 -0500, Josh Sled wrote:
> On Tue, 2007-01-16 at 12:58 +0100, Andreas Köhler wrote:
> > currently the code base depends on GLib >= 2.4, Pango >= 1.6 and GTK+ >=
> > 2.4. I would like to propose higher base versions, at least for GLib,
> > better for all three of them.
> [deletia]
> > There might be other reasons, like removing the burden to check whether
> > a GLib/Gtk 2.6 feature is worth single-casing it. What do you think?
> Yeah, we should treat them as a triple...


> Assuming we get 2.2 out the door in April, that means the 6 month
> dependency window is October 2006 ... which is about when Ubuntu,
> Mandriva and Fedora Core last released ... Suse was in December, and
> Debian just doesn't work that way.
> In any case, gtk 2.8 seems acceptable, and gtk+-2.10 is almost in there
> (except for Suse).
> So, should we go to 2.6, or 2.8?  I say 2.8. RHEL4 users have
> gnucash-2.0.4 to get them by, and we're not really helping them by
> restricting ourselves to 2.6 if they're still on 2.4.

I think we should migrate to at least 2.6 so that we can support a win32
release, eliminate the cloned glib 2.6 code in lib/glib26, and remove
the code that's conditionally compiled for pre/post glib26 and gtk26.
If we're not using any new-in-gtk-2.8 features I don't see any need to
bump the dependency that high.  If we are using 2.8 features, I have no
problem bumping the dependency given the timing windows mentioned above.


More information about the gnucash-devel mailing list