Raise dependency versions of GLib, Pango and GTK+

Josh Sled jsled at asynchronous.org
Wed Jan 17 20:42:13 EST 2007

On Tue, 2007-01-16 at 12:58 +0100, Andreas Köhler wrote:
> currently the code base depends on GLib >= 2.4, Pango >= 1.6 and GTK+ >=
> 2.4. I would like to propose higher base versions, at least for GLib,
> better for all three of them.
> There might be other reasons, like removing the burden to check whether
> a GLib/Gtk 2.6 feature is worth single-casing it. What do you think?

Yeah, we should treat them as a triple...

I updated README.dependencies with the status of a catch-all "gtk+"
verison number (from distrowatch) for the last two releases of the top 5

Assuming we get 2.2 out the door in April, that means the 6 month
dependency window is October 2006 ... which is about when Ubuntu,
Mandriva and Fedora Core last released ... Suse was in December, and
Debian just doesn't work that way.

In any case, gtk 2.8 seems acceptable, and gtk+-2.10 is almost in there
(except for Suse).

So, should we go to 2.6, or 2.8?  I say 2.8. RHEL4 users have
gnucash-2.0.4 to get them by, and we're not really helping them by
restricting ourselves to 2.6 if they're still on 2.4.

http://asynchronous.org/ - a=jsled;b=asynchronous.org;echo ${a}@${b}
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.gnucash.org/pipermail/gnucash-devel/attachments/20070117/78ea22ec/attachment.bin 

More information about the gnucash-devel mailing list