undefined reference to gnome-utils functions

Andreas Köhler andi5.py at gmx.net
Thu Mar 22 04:26:17 EDT 2007


Am Donnerstag, den 22.03.2007, 00:05 -0400 schrieb Nathan Buchanan:
> I was able to solve the crash of pexports.exe by replacing line 669 of
> install.sh with
> cd ..
> pexports -h include/htmlhelp.h $_HHCTRL_OCX > lib/htmlhelp.def
> cd lib
> I'm a bit stumped as to why it didn't like the original line: 
> pexports -h ../include/htmlhelp.h $_HHCTRL_OCX > htmlhelp.def

Interesting.  It is pretty reliable: Just close all MSYS windows, then
open a new one and execute one of the following two commands

$ cd /C/soft/hh/lib ; pexports -h ../include/htmlhelp.h $(which
hhctrl.ocx) > htmlhelp.def
$ cd /C/soft/hh ; pexports -h include/htmlhelp.h $(which hhctrl.ocx) >

The second always worked for me, while the first crashed unless executed
after the second or inside a complete install.sh run.  Well, I hope that
is fixed now in r15747.

> It built up until it needed docbook-xsl. It seems I need to track down
> the package manually as Dave mentioned in another thread.

I will try to patch this somehow, maybe with the help of fallback
mirrors or some redirection URL if there is one.

> Other than that, I still get messages about 
> libtool: link: warning: `/c/soft/guile/lib/libguile.la' seems to be
> moved
> libtool: link: warning: `/c/soft/guile/lib/libguile-ltdl.la' seems to
> be moved
> but so far they have not prevented the build 

You can safely ignore those.

> Thanks for all your help so far.

Thank _you_ for all your work!  Keep it up, might be nice to have binary
packages again ;-)

> Nathan

-- andi5

More information about the gnucash-devel mailing list