Problems downloading stock quotes [RESOLVED] possible security issue

Phil Longstaff plongstaff at
Wed Oct 17 14:11:49 EDT 2007

   What quote source do you use?  I know that F::Q reads the html from your
   quote  source  and  parses  the html to find the quote.  Perhaps it is
   downloading the advertising from that site as well.
   Richard Geddes wrote:


I finally resolved my problem... took a little head scratching.

I forgot I modified my hosts file as specified by:

ad blocker [1]<>

this modifies the hosts file so that all known advertising sources are
aliased to

I was trying to pinpoint exactly which advertising source
Finance::Quotes modules requires to get the stock quotes, but it seems
like it changes...  seems like the authors of Finance::Quotes are
involved in some advertising scheme...

hope they are not sending other info, in particular, my financial
information to these advertisers.

You're a security guy... what do you make of this?


Derek Atkins wrote:

What happens when you try gnc-fq-dump ?
Maybe your quote source changed their website?


Richard Geddes [2]<rich.geddes at> writes:

I was using GNUCash 2.0.5 on Ubuntu 7.04 for the last several months.  Set up s
ome stock investments and downloaded stock prices with Tools -> Price Editor ->
 Get Quotes.  This worked ok until about 3 weeks ago.  Now I get a message "The
re was an unknown error while retrieving the price quotes."

I did install a firewall management program called "Firestarter" between the ti
me gnucash was working and when it stopped working... I've since  uninstalled F
irestarter.  I tried getting stock quotes after stopping my firewall using "/et
c/init.d/iptables stop".  No difference.

I also upgraded to gnucash 2.2.1.  No dice.

I uninstalled gnucash altogether and reinstalled it, but still getting the same

I even thought of uninstalling perl as the module gnucash uses to get the quote
s is in perl... but, it seems that many apps on my system depend on perl... on
my ubuntu system, if I try to uninstall perl, it also includes (to uninstall) p
retty much all the apps I've installed.. does that sound correct...?

Anyway, my beef isn't really with perl, although it seems that if there was som
ething goes wrong with perl, alot of things depending on it would also go down.
... I just want to get my stock quotes so I can see my current asset values to
make decisions without pulling out the calculator.

Can someone help me troubleshoot this problem?  Thanks.


gnucash-devel mailing list
[3]gnucash-devel at

gnucash-devel mailing list
[5]gnucash-devel at


   2. mailto:rich.geddes at
   3. mailto:gnucash-devel at
   5. mailto:gnucash-devel at

More information about the gnucash-devel mailing list