ofxdirectconnect in aqbanking3 branch

Dave Reiser dbreiser at earthlink.net
Mon Jul 21 02:07:54 EDT 2008

-----Original Message-----
>From: Andreas Köhler 
>Sent: Jul 20, 2008 6:49 AM

>> There is still a problem, because the ofx data clearly contain  
>> transactions that should be imported, and gnucash is oblivious.
>Does r17347 change anything for you?

Yes. For credit card accounts, the matcher window now appears.

However, the first time I ran a directconnect session, gnucash asked me twice to specify an account for the credit card transactions I was downloading. Subsequent runs to the same bank only asked me once to specify an account (the Select Account dialog/window). I don't think gnucash should ever ask for an account during a directconnect sequence -- the Online Banking Setup function is supposed to take care of that. Gnucash won't even let me trigger the Get Transaction function unless there is an Online Setup match already established for the current account register.

Another problem is that all the descriptions showed up in the Transaction Matcher as 'unspecified'. Description should contain the contents of the OFX tag <NAME> or <MEMO>. My credit card company puts it in <NAME>, the investment broker in <MEMO>. Having all those descriptions show up as Unspecified makes matching difficult to impossible.

The Transaction Matcher window should be drawn in front of the main window, or it's pretty easy to lose it. (Hey, where are my transactions?)

I'm pretty sure this next bit is an aqbanking issue, but it has always bugged me: For nearly all my accounts, the Memo field in the Transaction Matcher window shows up as "Account Unknown Bank Unknown". One of my two banks sends something useful that gets inserted in that field, but none of my credit card or investment accounts has ever had anything but "Account Unknown Bank Unknown" there. Having all that extra useless text bugs me. :)

I still cannot connect to my main investment broker using aqbanking3. I still get a network error on every connection attempt. I can successfully connect with aqbanking2, and the ofx.log file shows identical ofx queries for both (except for the timestamps in NEWFILEUID, <DTCLIENT>, and <TRNUID>). Martin, something is different between aqbanking/gwen 3 and 2 that isn't showing up in ofx.log.

Also, unfortunately, the register window after a Transaction Matcher session still shows transactions which were rejected during the matching step. Sometimes that leads to a crash, but I haven't been able to replicate the crash on either single transactions or as many as 30 imported transactions. But it happens to me with some regularity on my 3 year-long data file and large imports. This bug is fairly long-standing, so it probably shouldn't hold you up this week.


More information about the gnucash-devel mailing list