data dropped when upgrading from 1.8.9 to 2.2

Derek Atkins warlord at MIT.EDU
Tue Oct 7 09:38:20 EDT 2008


Richard Bradley <Richard.Bradley at> writes:

> Derek Atkins wrote:
>>>I used gnucash for quite a while on FreeBSD, using version 1.8.9.
>>>I'm trying to upgrade to the current version, but it seems to drop a load
>>>of my data when importing the old accounts file.
>>What do you mean by this?  What gets "dropped"?  GnuCash shouldn't
>>drop data, but also there has not been a lot of testing going from 1.8
>>to 2.2 without going through the 2.0 release.  It SHOULDN'T be a
>>problem, because the XML format doesn't have a lot of differences.
> What I mean is that some account totals are different in 2.2 to what
> they were in 1.8, and quite a few line items don't appear in the
> affected accounts.

What account totals are different?
Have you looked in those accounts to compare what you see from before?

> It seems like some of the transactions just haven't been loaded.

I doubt that they are not loaded.  That seems pretty far fetched.

> I'm not 100% certain that there isn't just a new filter or something
> which is causing some transactions to be hidden (but why would that
> affect the totals?).

That is true.  Do you have multiple currencies?  Stocks?

>>> 2) How do I build gnucash from source on ubuntu "heron"?
>>apt-get build-dep gnucash
> Yes, I've done that, and it did install loads of packages. However, I
> still get "Unknown library `print`" from "gnome-config --libs print"
> Sorry for not mentioning this straight away, but I'm trying to build
> the 1.8.9 release, because my plan was to double check the differences
> in behaviour, and then compare the code which loads the data between
> the two.

OOOOHHHHH!!!!! You didn't say you wanted to build 1.8!  That's a
COMPLETELY different animal.

> Is it still possible to build 1.8.9? Do you think that the "unknown
> library" issue is due to trying to build too old a version?

I have no idea.  It requires a complete Gnome-1 build environment,
which probably isn't available anymore.

> I haven't yet tried to build 2.2, but I'll have a go tonight.
> Are you running ubuntu? Does "gnome-config --libs print" work for you?
> If so, can you determine which package provided the file
> in /usr/lib (this is what "gnome-config --libs print" defers to, I
> think).

Nope, I am not running Ubuntu.  And Fedora 7 doesn't have Gnome-1

>> there has not been a lot of testing going from 1.8
>> to 2.2 without going through the 2.0 release.
> I could try loading the accounts through 1.8 -> 2.0 -> 2.2, if you
> think that would help?

It might?

> Thanks,
> Rich


       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL:    PP-ASEL-IA     N1NWH
       warlord at MIT.EDU                        PGP key available

More information about the gnucash-devel mailing list