crash in 2.3.8 Transaction Report

Graham Menhennitt graham at
Sat Dec 12 19:21:39 EST 2009


I'm seeing a crash in 2.3.8 when setting options in a Transaction
report. I'm 99% sure that this didn't happen in 2.3.7. If required, I
can rebuild 2.3.7 and try it. I've tried running Check & Repair All to
make sure I have no errors in my file, but it still happens.

I open my GnuCash XML file and select Reports->Transaction Report - the
report opens correctly. I then open the Report Options dialog, on the
Accounts tab select a single account and press Apply or Ok. Gnucash
immediately crashes with "Segmentation Violation". If I run with
--debug, the last few lines of the gnucash.trace file contain:

* 11:06:09  WARN <GLib-GObject> invalid cast from
`GncTreeModelAccountDrag' to `GtkTreeModelSort'
* 11:06:09  CRIT <Gtk> gtk_tree_model_sort_convert_iter_to_child_iter:
assertion `GTK_IS_TREE_MODEL_SORT (tree_model_sort)' failed
* 11:06:09  WARN <GLib-GObject> invalid cast from
`GncTreeModelAccountDrag' to `GtkTreeModelSort'
* 11:06:09  CRIT <Gtk> gtk_tree_model_sort_get_model: assertion
`GTK_IS_TREE_MODEL_SORT (tree_model)' failed
* 11:06:09  CRIT <Gtk> gtk_tree_model_filter_convert_iter_to_child_iter:
assertion `GTK_IS_TREE_MODEL_FILTER (filter)' failed


More information about the gnucash-devel mailing list