Patch Re: Bug 625193 To move utils to core

Mike Evans mikee at
Tue Aug 17 16:39:28 EDT 2010

On Tuesday August 17 2010 20:54:42 Christian Stimming wrote:
> Am Monday 16 August 2010 schrieb Mike Evans:
> > I've attached a patch to move utils.c utils.h to src/engine as discussed
> > in Bug 625193.
> Committed to SVN, thanks.
> One suggestion for the function naming (in gncIDsearch.h): The functions
> which belong to a hypothetical "core gnucash library" should all begin
> with "gnc_", and the next word may or may not point to the main object on
> which this function operates. In this case, I'd suggest one of the
> following namings: * gnc_search_customer_on_id
> * gnc_book_search_by_id_customer
> * gnc_book_search_customer_by_id

Will do.  I wasn't sure about naming conventions.  I  also realised (just 
after posting) that much re-factoring is required and that I missed vendors 
out, so I will have to re-patch anyway.

Thanks and Regards MikeE

GPG Key: 1024D/050895C2
Search String: 0x050895C2

More information about the gnucash-devel mailing list