gnucash exits with error when using libglib20-0 version 2.25.1

Greg Long glong at
Wed Aug 18 16:20:51 EDT 2010


Just wanted to give the developers a head up on a problem I ran into with Ubuntu 10.04.1 running gnucash 2.3.14 or the most current 2.3.14 svn (r19439)

The 2.3.14 version worked fine until about 3 weeks ago, and then the program started crashing.  That is when I acquired the SVN version and compiled.

I tracked it down to a problem with the libglib version installed from a Rhythmbox PPA.  When I reverted to the previous version with ppa-purge (my current version is 2.24.1)  the problem resolved.
So it appears that there is a conflict with that library.  I was able to track down dmesg and the gnucash debug log.  However, since recompiling and reverting I do not have that error log anymore.  (Hindsight is 20:20)

If it is important I can probably reinstall the rythmbox PPA and run and replicate the error. (It happened every time with the 2.25.1 version of libglib).  Scenario:  I would pull up a report and when I tried to close the program would crash.  Upon restarting the report window would still be there, so there was no way to get rid of report windows once they were called up. Same problem with every report (standard or custom).  Hope this is helpful. 

Greg Long

Gregory J. Long, Ph.D.
Dept. of Biology
Olivet Nazarene University
Bourbonnais, IL 60914

More information about the gnucash-devel mailing list