Account stopped rendering

Michael Brade brade at
Sun Feb 14 11:06:28 EST 2010

Hi again,

it's been a week now and no answers? Aren't you interested in fixing this?

I have now tried a few other things: The old 2.2.6 debian packages fail with a 
segfault. So I went to great lengths and compiled the 2.2.6 svn-tag on my 
system with debugging enabled. I've had to fix many deprecated function calls, 
make some fixes in gtkhtml and goffice and it finally compiled successfully. And 
then it crashed again with a bt:

#0  0xb69ea17e in set_dimensions_pass_one (sheet=0x8a18020, cursor=0x8605ce8, 
dimensions=0x8a141a8) at gnucash-style.c:177
#1  0xb69eaa66 in styles_recompute_layout_dimensions (sheet=0x8a18020, 
default_width=680) at gnucash-style.c:493
#2  0xb69eab3f in gnucash_sheet_styles_set_dimensions (sheet=0x8a18020, 
default_width=680) at gnucash-style.c:506
#3  0xb69eb386 in gnucash_sheet_compile_styles (sheet=0x8a18020) at gnucash-
#4  0xb69ec91c in gnc_table_init_gui (widget=0x86bb5c8, data=0x8408020) at 
#5  0xb72d6f35 in gsr_create_table (gsr=0x8a12040) at gnc-split-reg.c:387
#6  0xb72d6e0e in gnc_split_reg_init2 (gsr=0x8a12040) at gnc-split-reg.c:353
#7  0xb72d6d09 in gnc_split_reg_new (ld=0x85814b8, parent=0x814d000, 
numberOfLines=10, read_only=0) at gnc-split-reg.c:325
#8  0xb72cdd08 in gnc_plugin_page_register_create_widget 
(plugin_page=0x86a9020) at gnc-plugin-page-register.c:727
#9  0xb722606a in gnc_plugin_page_create_widget (plugin_page=0x86a9020) at 
#10 0xb721bd65 in gnc_main_window_open_page (window=0x814d000, 
page=0x86a9020) at gnc-main-window.c:2211
#11 0xb72cecf5 in gnc_plugin_page_register_recreate_page (window=0x814d000, 
key_file=0x832c118, group_name=0x8182fa0 "Page 2") at gnc-plugin-page-
#12 0xb72266d3 in gnc_plugin_page_recreate_page (window=0x814d000, 
page_type=0x833dcb0 "GncPluginPageRegister", key_file=0x832c118, 
page_group=0x8182fa0 "Page 2") at gnc-plugin-page.c:260
#13 0xb7216cea in gnc_main_window_restore_page (window=0x814d000, 
data=0xbfffec3c) at gnc-main-window.c:501
#14 0xb721778b in gnc_main_window_restore_window (window=0x814d000, 
data=0xbfffec3c) at gnc-main-window.c:692
#15 0xb7217aee in gnc_main_window_restore_all_windows (keyfile=0x832c118) at 
#16 0xb72de630 in gnc_restore_all_state (session=0x83350d0, unused=0x0) at 
#17 0xb734b5e8 in call_c_hook (hook=0x8329e60, data=0x83350d0) at gnc-
#18 0xb7406b26 in g_hook_list_marshal () from /lib/
#19 0xb734b760 in gnc_hook_run (name=0xb72680f6 "hook_book_opened", 
data=0x83350d0) at gnc-hooks.c:277
#20 0xb720b745 in gnc_book_opened () at gnc-file.c:499
#21 0xb720bfc4 in gnc_post_file_open (filename=0x8336220 
"/home/rohan/Addresses/Cash-Michael") at gnc-file.c:834
#22 0xb720c0d5 in gnc_file_open_file (newfile=0x8336220 
"/home/rohan/Addresses/Cash-Michael") at gnc-file.c:877
#23 0x0804cc3a in inner_main (closure=0x0, argc=1, argv=0xbffff1a4) at gnucash-
#24 0xb7f46366 in ?? () from /usr/lib/
#25 0xb7f17082 in ?? () from /usr/lib/
#26 0xb7f8e073 in scm_c_catch () from /usr/lib/
#27 0xb7f17637 in scm_i_with_continuation_barrier () from 
#28 0xb7f17713 in scm_c_with_continuation_barrier () from 
#29 0xb7f8cd89 in scm_i_with_guile_and_parent () from /usr/lib/
#30 0xb7f8cdde in scm_with_guile () from /usr/lib/
#31 0xb7f462ff in scm_boot_guile () from /usr/lib/
#32 0x0804d096 in main (argc=1, argv=0xbffff1a4) at gnucash-bin.c:624

However, gnucash 2.2.6 seems to crash when opening any account, so I'm not 
sure if the bt really helps :-( Might be that 2.2.6 doesn't like the current 
glib/gnome/whatever libs.

I have also been able to store my whole data on a mysql database with the 
gnucash trunk version from 6 days ago. Looks ok. Still doesn't render though.

Just a few minutes ago I have done an "svn up" on trunk and now nothing 
renders anymore. Just a grey window is left.

And finally, I have been able to use kmymoney on the gnucash file and convert 
it. At a glance everything seems to be fine. So if noone is going to help me on 
this I will *have* to switch to kmymoney :-( I cannot afford to wait much 


On Sunday 07 February 2010 12:37:49 Michael Brade wrote:
> Hi,
> I am running Debian unstable with Gnucash 2.2.9. Since Dec, 6th, my cash
> account stopped being rendered when opened. The tab is still shown with the
> title "Bargeld", the headers of the table inside are all there (like Date,
> Num, Description, etc.) and so is the footer (with Present, Future, etc.).
> However, the contents are empty, nothing is drawn. If I switch to another
>  tab and back the contents of the old tab are left unchanged in the new
>  view.
> I thought it was just a bug in one debian build but it hasn't changed ever
> since. Now I found out that I can scroll up and entries are shown properly
>  up until 04/12/2008. Everything after the following entry is not rendered
>  anymore. I have had a look at the xml but cannot find anything obviously
>  wrong. Now I have compiled the current svn but still no luck, the same bug
>  shows up.
> Can anyone tell me how to debug this? Or do you know how to fix this? Do
>  you need more information?
> Any help is greatly appreciated! Please CC me, I'm not on the list (yet).
> Cheers,
>   Michael

Michael Brade;                                              KDE Developer
  |-mail: echo brade !#|tr -d "c oh"|s\e\d 's/e/\@/2;s/$/.org/;s/bra/k/2'

KDE 4: Beyond Your Expectations

More information about the gnucash-devel mailing list