Build dependencies (was: Re: Request: require glib2 >= 2.12)

Geert Janssens janssens-geert at
Sat Feb 20 11:55:05 EST 2010

On Saturday 20 February 2010, Christian Stimming wrote:
> Am Freitag, 19. Februar 2010 schrieb Geert Janssens:
> > I'd like to bump the minimum required glib2 for the 2.3.x series to 2.12.
> I'm all in for raising our minimum required version to some higher and more
> recent value.
> My main reason is that all of us developers use more recent versions, which
> means we also test only on the more recent versions. Even if we pretend the
> older versions might still compile, they are for sure not tested at all.
> Eventually we're better off to say the old versions are neither tested nor
>  can be used for compiling instead of saying they might be used for
>  compiling but we have no idea whether they still work.
> Hence, I'm all in for glib2-2.12 and even higher versions.
glib2-2.12 is the new base version. Reason is that RHEL5 ships it, which is 
the most conservative, yet still maintained disto we care about.

> The gtk requirement should be updated as well, I guess.
I'm currently working on this one. Gtk 2.10 will be the base for now. I did 
request an upgrade on the RHEL bugzilla to at least 2.12. We will need this if 
we want to remove deprecated functions and be compatible with gnome 3. But 
that's a concern for after 2.4.

I do wish we could set a higher base for guile though. It's about the only 
dependency left that requires a special compat header file. Upgrading this one 
before the final 2.4 release allows me to do some additional code refactoring 
for a more consistent use of the guile api. I started this just before new 
year due to incompatibilities with guile 1.8.6+.

Doing this refactoring before 2.4 is branched will make it easier to backport 
patches from trunk to the 2.4 later. I the refactoring happened after the 
branch, it will be harder to backport (because the code bases diverged).

For linux distro's there's no problem. All current distros ship 1.8+

The issue here is the windows build. It is still configured to use 1.6. Since 
we're working in the dependency areo on the windows build atm, it may be a 
good time to switch to 1.8 there as well ?


More information about the gnucash-devel mailing list