Build dependencies (was: Re: Request: require glib2 >= 2.12)

John Ralls jralls at
Sat Feb 20 20:05:18 EST 2010

On Feb 20, 2010, at 10:32 AM, John Ralls wrote:

> I too am using Guile 1.6 with OSX, because when I set up the builds in late 2008 Gnucash had problems with 1.8 and I haven't tried again since. I'll do so today or tomorrow and report back. 

Gnucash trunk won't build with Guile 1.8.7 (the current release):
> Making all in engine
> chmod u+x ./iso-currencies-to-c
> GUILE_LOAD_PATH=../../lib/: srcdir=. ./iso-currencies-to-c
> ERROR: Loaded gnucash srfi-2.scm in unknown Guile version:1.8.7.
> If you're running a Guile newer than 1.4, then this file should
> not have been installed.  Please report the bug.

The problem is in src/engine/iso-currencies-to-c, which is a scheme file whose first line is:
(use-modules (srfi srfi-2))

Removing that line (so that srfi-2 isn't invoked) causes the following error:
ERROR: Unbound variable: and-let*

I don't have time to troubleshoot this further tonight.

John Ralls

More information about the gnucash-devel mailing list