Gnucash for Android beta1 release

Ngewi Fet ngewif at
Tue Aug 21 04:51:31 EDT 2012

On Tue, Aug 21, 2012 at 12:10 AM, David Carlson <carlson.dl at>wrote:

>  On 8/20/2012 3:34 PM, Ngewi Fet wrote:
> Hi David,
> From what you describe, you don't need a tutorial :). You did everything
> right.
> I could always export successfully with Gmail. I also just configured a
> yahoo account and tested again and I can get the file ok. So there must be
> something going wrong with the sending in your email client.
> The file is sent with plain xml mime type, so there should be no problems
> there. Try with another mail client and see if you get the same problem.
>  Cheers,
> Ngewi
>  On Mon, Aug 20, 2012 at 5:49 PM, David Carlson <carlson.dl at>wrote:
>> On 8/20/2012 8:41 AM, Ngewi Fet wrote:
>> (snip)
>> Hi Ngewi,
>> I think that I need a tutorial.  I installed the beta to my Samsung
>> Rugby II Android phone with no problem, accepted the default income and
>> expense accounts, entered a test transaction with no problem, but when I
>> tried to export the file had a problem.
>> I chose the sharefile option which led me to use one of my email
>> accounts to send an email.  I chose to send to another of my accounts.
>> That worked, but the email that arrived at my computer did not appear to
>> have an attachment, either in my yahoo webmail page or in my local
>> Thunderbird after it was downloaded.  From Thunderbird, at least, I was
>> able to view the raw message.  I found that there was an attachment in
>> base64 with the following header(s):
>> --00504502e1a9d1e41804c7b3e07e
>> Content-Type: text/html; charset=ISO-8859-1
>> <p>Gnucash accounts export from 2012.08.20 10:06</p>
>> <p>Sent from my Android - David </p>
>> --00504502e1a9d1e41804c7b3e07e--
>> --00504502e1a9d1e41e04c7b3e081
>> Content-Type: multipart/xml; name="20120820_1005_gnucash_all.ofx"
>> Content-Disposition: attachment; filename="20120820_1005_gnucash_all.ofx"
>> Content-Transfer-Encoding: base64
>> X-Attachment-Id: 1410833030125479060-1
>> Can you tell me why the attachment is not accessible in my email program?
>> David C
>> _______________________________________________
>> gnucash-devel mailing list
>> gnucash-devel at
>  Sorry for the delay, I needed to re-install my email program to fix it
> to send from my yahoo account.
> That worked, and the ofx file appears nicely in Thunderbird without
> needing to look at the raw text or save the attachment, although I probably
> do need to save it to import into GnuCash.
> However, right after that success I repeated sending it via gmail directly
> from the Android ap and the attachment is still invisible and not
> identified by any icon in att/yahoo webmail or in Thunderbird.  I will next
> try sending a file saved to my SD card and see what happens.

GnucashMobile first saves the file to the SD card and then triggers an
Intent to send a mail with the attachment. By the time email is sent, the
OFX file exists completely on disk.
So basically at that point, it is pure Android mechanics which are at work.
It sounds to me like more of a yahoo issue, or maybe the file is not being
completely sent somehow.

One thing that comes to mind is that Yahoo! might be choking on the mime
type. GnucashMobile sends the attachment as multipart/xml.
This was used instead of text/xml because when declared as text, every
other app on your phone will want to accept your OFX file (IM clients
etc). That is behaviour we do not want.
I will experiment with the mime type and see if that makes a difference.
Thanks for the report.


> David C

More information about the gnucash-devel mailing list