Error building gnucash with macports to a custom location

reubano reubano at
Mon Feb 27 13:21:43 EST 2012

reubano wrote
> Mike Alexander wrote
>> --On February 25, 2012 12:53:04 PM -0800 reubano <reubano@> 
>> wrote:
>>> This happened with guile the first time and I fixed it by installing
>>> guile and slib-guile into /opt/local. Any idea how to fix this?
>> You probably need to set PKG_CONFIG_PATH and PKG_CONFIG.  I used to 
>> build both the Aqua and X11 versions of Gnucash with Macports building 
>> the dependencies using a Perl script that contains these lines 
>> (slightly edited):
>>       $ENV{ "CPPFLAGS" } = "-I$macports_dir/include";
>>       $ENV{ "LDFLAGS" } = "-L$macports_dir/lib";
>>       $ENV{ "PKG_CONFIG_PATH" } = 
>> "$macports_dir/lib/pkgconfig:$macports_dir/share/pkgconfig:$ENV{\"PKG_CONFIG_PATH\"}";
>>       $ENV{ "PKG_CONFIG" } = "$macports_dir/bin/pkg-config";
> Still not working. I tried adding
> export
> PKG_CONFIG_PATH="/opt/x11/lib/pkgconfig:/opt/x11/share/pkgconfig:$PKG_CONFIG_PATH"
> export PKG_CONFIG="/opt/x11/bin/pkg-config"
>> where $macports_dir was either /opt/aqua or /opt/local (backwards from 
>> your two).  I still use this script for building the X11 version but 
>> not the Aqua version.
> How did you get the aqua version to build? I made a new macports directory
> because the current one has gtk2 @2.24.10_0+no_x11+quartz which 
> prevented gnome from building 

It turns out the problem was the path env. I added 


and it stopped looking in /opt/local. There was another error about
lib_goffice missing. There is no port with that name, but there is goffice.
I installed that and the configure finally worked.

View this message in context:
Sent from the GnuCash - Dev mailing list archive at

More information about the gnucash-devel mailing list