jhbuild error on Mac OSX Lion

reubano reubano at gmail.com
Wed Jan 4 03:59:15 EST 2012

I can't get jhbuild to work for me. I followed the instructions at
http://live.gnome.org/GTK%2B/OSX/Building#Procedure but using Xcode 4.2. I
made a new user and ran 

    sh gtk-osx-build-setup.sh

However, when I ran 

    jhbuild build python

I got the following:

*** Configuring python *** [1/1]
./configure --prefix /Users/admin/gnucash-stable --libdir
'/Users/admin/gnucash-stable/lib' --enable-shared  
checking for --enable-universalsdk... no
checking for --with-universal-archs... 32-bit
checking MACHDEP... darwin
checking machine type as reported by uname -m... x86_64
checking for --without-gcc... no
checking for gcc... /usr/bin/gcc-4.2
checking whether the C compiler works... no
configure: error: in `/Users/admin/gtk/source/Python-2.7.2':
configure: error: C compiler cannot create executables
See `config.log' for more details
*** Error during phase configure of python: ########## Error running
./configure --prefix /Users/admin/gnucash-stable --libdir
'/Users/admin/gnucash-stable/lib' --enable-shared   *** [1/1]

  [1] Rerun phase configure
  [2] Ignore error and continue to build
  [3] Give up on module
  [4] Start shell
  [5] Reload configuration
  [6] Go to phase "wipe directory and start over"
  [7] Go to phase "clean"
  [8] Go to phase "distclean"

And the same errors occurred when I tried to run 

    jhbuild bootstrap

I also tried copying
http://github.com/jralls/gnucash-on-osx/raw/master/.jhbuildrc-custom into
~/.jhbuildrc-custom to see if it made a difference and it did not help. 

View this message in context: http://gnucash.1415818.n4.nabble.com/jhbuild-error-on-Mac-OSX-Lion-tp4260521p4260521.html
Sent from the GnuCash - Dev mailing list archive at Nabble.com.

More information about the gnucash-devel mailing list