marking a transaction cleared "c" causes malfunction of program

Donald Allen donaldcallen at
Sun Jan 15 19:37:19 EST 2012

On Sun, Jan 15, 2012 at 7:08 PM, Markus Scheffler <markus1611 at>wrote:

>  Thanks Don for your feedback. I should have been more precise. Could you
> please try marking a transaction cleared "c" and click with the
> cursor on another transaction - not enter (usually this way you got a
> message whether you wanna safe the transaction). If I use the enter button
> it works fine, just clicking on another transaction causes the mentioned
> behaviour.

I just tried this on the same machine/setup I mentioned earlier. I changed
a transaction to 'cleared' and then clicked another transaction without
recording the first one. Got the usual pop-up, clicked 'Record changes',
and all was well. I did this with gnucash talking to my data stored in
postgres, so guessing that you are not doing that, I saved the data to an
xml file. (When I did that, the register failed to get repainted properly
after having been covered by the file dialog box, so this is a bug. I
forced repainting by scrolling the register, which fixed it. This is a bug.
I will file a bug report. ) I did this to account for the extremely
unlikely possibility  that my use of the database prevented the problem you
observed. And so I did your test in a fresh instance of gnucash with the
xml file loaded and, as I expected, it worked correctly. So your problem
appears to be Windows-specific.


> I have just came across another "changed" behaviour. If I chose a date in
> a calendar (e.g. invoice) the calendar doesn't close any more. Before
> (2.4.8) I could double click a date and the calendar closed.
>  ------------------------------
> Original message
> From: "Donald Allen" <donaldcallen at>
> To: markus1611 at;
> Dated: 16/01/2012 5:12:05 AM
> Subject: Re: marking a transaction cleared "c" causes malfunction of
> program
> On Sat, Jan 14, 2012 at 8:31 PM, Markus Scheffler <markus1611 at>wrote:
>> Hi all,
>> tried to mark transaction cleared after upgrading to 2.4.9 from 2.4.8 on
>> windows xp. After selecting c in a transaction the program goes in to an
>> endless loop showing an empty popup. Have to manually abort the program. I
>> guess GTK problem.
> I just tried this on an old Thinkpad G41 that I use for experimenting. It
> is running the latest Debian stable (I really wish Debian and Ubuntu would
> lose those ridiculous release names!) and gnucash 2.4.9 installed, built
> from source. My gnucash data is in a postgresql (9.1.2, also built from
> source) database. I just tried marking a transaction 'cleared' and the
> behavior was completely normal.
> /Don
> _______________________________________________
>> gnucash-devel mailing list
>> gnucash-devel at

More information about the gnucash-devel mailing list