Re: marking a transaction cleared "c" causes malfunction of program

Markus Scheffler markus1611 at
Sun Jan 15 19:08:25 EST 2012

Thanks Don for your feedback. I should have been more precise. Could you please try marking a transaction cleared "c" and click with the cursor on another transaction - not enter (usually this way you got a message whether you wanna safe the transaction). If I use the enter button it works fine, just clicking on another transaction causes the mentioned behaviour.

I have just came across another "changed" behaviour. If I chose a date in a calendar (e.g. invoice) the calendar doesn't close any more. Before (2.4.8) I could double click a date and the calendar closed.


Original message

From: "Donald Allen" <donaldcallen at>

To: markus1611 at; 

Dated: 16/01/2012 5:12:05 AM

Subject: Re: marking a transaction cleared "c" causes malfunction of program

On Sat, Jan 14, 2012 at 8:31 PM, Markus Scheffler <markus1611 at> wrote:

Hi all,

tried to mark transaction cleared after upgrading to 2.4.9 from 2.4.8 on windows xp. After selecting c in a transaction the program goes in to an endless loop showing an empty popup. Have to manually abort the program. I guess GTK problem.

I just tried this on an old Thinkpad G41 that I use for experimenting. It is running the latest Debian stable (I really wish Debian and Ubuntu would lose those ridiculous release names!) and gnucash 2.4.9 installed, built from source. My gnucash data is in a postgresql (9.1.2, also built from source) database. I just tried marking a transaction 'cleared' and the behavior was completely normal.



gnucash-devel mailing list

gnucash-devel at

More information about the gnucash-devel mailing list