packaging/win32/ fails with wget error

Randy Galbraith randy.galbraith at
Sat Jul 6 21:43:05 EDT 2013

Hi Everyone,

I worked through the libguile 1.8.8 compile errors by creating patch files
and running them within packaging/win32/

            echo "RandyG: inst_guile grep done..."
            patch -p0 -b </c/Soft/work/config.h.patch
            patch -p0 -b </c/Soft/work/async.c.patch
            patch -p0 -b </c/Soft/work/fports.c.patch
            patch -p0 -b </c/Soft/work/gc-segment.c.patch
            patch -p0 -b </c/Soft/work/i18n.c.patch
            patch -p0 -b </c/Soft/work/scmsigs.c.patch
            patch -p0 -b </c/Soft/work/stacks.c.patch
            patch -p0 -b </c/Soft/work/srfi-4.c.patch
            patch -p0 -b </c/Soft/work/srfi-13.c.patch
            patch -p0 -b </c/Soft/work/threads.c.patch
            patch -p0 -b </c/Soft/work/threads2.c.patch
            patch -p0 -b </c/Soft/work/throw.c.patch
            patch -p0 -b </c/Soft/work/unif.c.patch
            patch -p0 -b </c/Soft/work/filesys.c.patch
            patch -p0 -b </c/Soft/work/filesys2.c.patch
            echo "RandyG: BINGO PATCH"

Most of these patches simply remove an unused variable.  The config.h.patch
removes the #define HAVE_STRUCT_TIMESPEC that was second thing in this
thread.  This of course would need a better fix, since I have not chased
down why config.h was generated in this manner.  I have posted to the Guile
developers list information about the unused variables to see if they would
be interested in these patch files.

Now on to the next problem.  The run of gets to this point...

RandyG: step is inst_libdbi
(my echo here)

then ends with...

if /bin/sh ./libtool --tag=CC --mode=compile gcc -DPACKAGE_NAME=\"sqlite\"
-DPACKAGE_STRING=\"sqlite\ 3.6.1\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"sqlite\" -DVERSION=\"3.6.1\"
-I. -I.    -DSQLITE_THREADSAFE=1  -g -O2 -MT sqlite3.lo -MD -MP -MF
".deps/sqlite3.Tpo" -c -o sqlite3.lo sqlite3.c; \
    then mv -f ".deps/sqlite3.Tpo" ".deps/sqlite3.Plo"; else rm -f
".deps/sqlite3.Tpo"; exit 1; fi
./libtool: line 873: X--tag=CC: command not found
./libtool: line 906: libtool: ignoring unknown tag : command not found
./libtool: line 873: X--mode=compile: command not found

As I find more time, I'll chase down why libtool fails here.  Any
information, encouragement, etc, appreciated.


On Sun, Jun 23, 2013 at 8:25 AM, Randy Galbraith
<randy.galbraith at>wrote:

> Hi Everyone,
> Likely not the best fix, but I was able to work around this issue by
> copying several .dll files into tools/bin. Here is some terminal output
> showing what was copied...
> $ ls *.dll
> exchndl.dll  msys-crypto-1.0.0.dll  msys-iconv-2.dll  msys-intl-8.dll
> msys-ssl-1.0.0.dll  unzip32.dll
> and from where...
> $ find . -name  msys-iconv-2.dll
> ./MinGW/msys/1.0/bin/msys-iconv-2.dll
> ./tools/bin/msys-iconv-2.dll
> This got be a bit further, then I ran into an issue with libpthread-2,
> whereupon I followed this advice..
> * Edit file $INSTALLER_DIR/ and comment out the following:
>         if [ "$CROSS_COMPILE" != "yes" ]; then
>             # Some preparation steps, only for native (non-cross-compile)
>            cp ${_MINGW_UDIR}/bin/libpthread-2.dll ${_MINGW_UDIR}/bin/pthreadGC2.dll
>         fi
> found here:
> which takes me to my current issue:
> "HAVE_STRUCT_TIMESPEC" redefined when compiling eval.x...
> here is the last the output:
> ./guile-snarf -o eval.x eval.c -DHAVE_CONFIG_H -I.. -I.. -I.. -I/C/Soft/readline/include -I/C/Soft/regex/include -I/C/Soft/autotools/include -I/C/Soft/gmp/include -D__MINGW32__ -D__MINGW32__ -Wall -Wmissing-prototypes -Werror
> In file included from eval.c:31:0,
>                  from eval.c:5997:
> ../config.h:625:0: error: "HAVE_STRUCT_TIMESPEC" redefined [-Werror]
> In file included from ../libguile/pthread-threads.h:28:0,
>                  from ../libguile/threads.h:33,
>                  from ../libguile/gc.h:28,
>                  from ../libguile/_scm.h:69,
>                  from eval.c:60:
> c:\soft\mingw\bin\../lib/gcc/mingw32/4.7.2/../../../../include/pthread.h:317:0: note: this is the location of the previous definition
> cc1.exe: all warnings being treated as errors
> make[2]: *** [eval.x] Error 1
> make[2]: Leaving directory `/C/Soft/tmp/guile-1.8.8/libguile'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/C/Soft/tmp/guile-1.8.8'
> make: *** [all] Error 2
> Any and all advice and encouragement appreciated.  I'll try and get back with the results further research.
> Cheers,
> -Randy
> On Sat, Jun 15, 2013 at 9:05 AM, Randy Galbraith <
> randy.galbraith at> wrote:
>> Hi Everyone,
>> I am attempting to setup an environment to compile gnucash in Windows
>> XP.  I have been following the instructions on the wiki where I get to the
>> point of running  This results in an error dialog box
>> appearing...
>> wget.exe - Unable To Locate Component
>> (X) This application has failed to start because msys-crypto-1.0.0.dll
>> was not found. Re-installing the application may fix this problem.
>> My understanding of msys and mingw is shallow, since I normally work on
>> GNU/Linux.  So this is likely the issue.  After a bit of searching and
>> reading documentation I decided to run this command at the bash prompt:
>> mingw-get install msys-wget
>> That did seem to install this package, alas the error continued to
>> happen.  I then added a set -x to to see how it ends...
>> +++
>> PATH='/C/Soft/tools/bin:.:/usr/local/bin:/mingw/bin:/bin:/c/WINDOWS/system32:/c/WINDOWS:/c/WINDOWS/System32/Wbem:/c/Program
>> Files/QuickTime/QTSystem/:/c/Soft/Git/cmd'
>> ++ quiet /C/Soft/tools/wget --version
>> ++ /C/Soft/tools/wget --version
>> ++ quiet wget --version
>> ++ wget --version
>> ++ mkdir -p /C/Soft/tools/bin
>> ++ tar -xjpf /C/Soft/downloads/wget-1.12-1-msys-1.0.13-bin.tar.bz2 -C
>> /C/Soft/tools
>> ++ cp '/C/Soft/tools/*/*/wget.exe' /C/Soft/tools/bin
>> cp: cannot stat `/C/Soft/tools/*/*/wget.exe': No such file or directory
>> Here is a bit more research...
>> Randy at ANNAXP /c/Soft
>> $ find . -name wget.exe
>> ./MinGW/msys/1.0/bin/wget.exe
>> ./tools/bin/wget.exe
>> Randy at ANNAXP /c/Soft
>> $ tools/bin/wget.exe --version
>> Randy at ANNAXP /c/Soft
>> $ MinGW/msys/1.0/bin/wget.exe --version
>> The run from tools/bin results in error dialog.  The run from
>> MinGW/msys... results in a hang.
>> Any help is appreciated.  In any regards I'll get back with any further
>> discoveries and/or fixes.
>> Cheers,
>> -Randy

More information about the gnucash-devel mailing list