Permission denied when running the script to install Finance::Quote under win XP

Cristian Marchi cri79 at
Mon Feb 24 16:53:58 EST 2014

Il 24/02/2014 17:14, John Ralls ha scritto:
> On Feb 24, 2014, at 7:25 AM, Cristian Marchi <cri79 at> wrote:
>> I run into a problem with the script that installs finance::quote under winsows XP. When i run the script, I always got a message about a permission denied in the instalaltion folder. I tried to use the "attrib" DOS command but it didn't work so, after a lot of researching, I found a solution with the following command (to run in a prompt):
>> cacls foldername /T /G "username":F
>> where
>> foldername is the folder where the Perl package has been downloaded (in my case "strawberry")
>> username is the name of the pc user
>> /T means recursively
>> /G assign acces rights (F in this case stands for full acces) to user "username"
>> I'm sending this just to have it available to all.
> Should this be done in the script itself?
> Regards,
> John Ralls
Don't really know if it was a problem on my side only and I was not able 
to discover when it appeared...I havn't heard of anyone having a similar 
problem so I don't know if including the command in the script can break 
something for others.


More information about the gnucash-devel mailing list