Building on Windows from scratch

Gary Bilkus mail at
Tue Jan 7 08:52:29 EST 2014

On 28/12/2013 08:16, Gary Bilkus wrote:
> Thanks Geert,
> I've got a bit further....the program now starts and then dies after 
> showing a splash screen.
> I found a gnucash-launcher.cmd script which didn't quite work, because 
> it was missing references to libxslt enchant and libsoup
> If I add those ( bin and lib ) to the path, the program no longer 
> complains, but dies almost immediately.
> If I run inside gdb, it seems to be failing somewhere in guile 
> initialization which causes the program to exit.
> I've also set up an XP VM and run on there under 32 bits, just to see 
> what happens. Same thing - it will compile OK, and dies at the same 
> point.
> My next stage will be to recompile guile and leave the tmp directory 
> around, so that gdb has source to work from, and see if a detailed 
> debug session shows up the problem. Unless you have a better idea!
> Gary

I've made some more progress on my attempts to compile gnucash on 
Windows from scratch.
Firstly, I've tried running everything on a 32 bit VM, and there's no 
real difference. Some of the compiler warnings go away, but the other 
problems remain.

So I did some debugging, and discovered that the first reason gnucash 
bombs out is that the guile dll names for libguile-srfi-srfi... in 
guile/bin are inconsistent with the names of the files being loaded by 
the corresponding scm file. I think this is because the versioning of 
libraries under unix assumes that the minor version is linked to the 
major version, but that hasn't happened under windows.
So I copied, for example libguile-srfi-srfi-1-v-3-3.dll to 
libguile-srfi-srfi-1-v-3-3.dll which seems to have fixed that problem.
I now get some debug output in the gnucash.trace...log files saying
...Could not locate module gnucash/app-utils interface v.0
............register/ledger-core ...register/register-gnome...........
for loads of the modules gnucash loads on start. So it bombs out there.

When I have a look in the guile-modules directory, I can see some of 
these, but nothing in the register subdirectory for example.
Any ideas? It seems so close now.

BTW, I've also tried building the newly released 2.6.0. It behaves 
identically up to this point, so from now on I will concentrate on 
trying to build 2.6 after first running Geerts install processes to 
create the necessary environment


More information about the gnucash-devel mailing list