build gnucash-git woes with Mac OS, Xcode 5.1

John Ralls jralls at
Sun Mar 16 13:58:43 EDT 2014

On Mar 16, 2014, at 8:37 AM, Jeff Earickson <jaearick at> wrote:

> John et al,
> I upgraded Xcode on my Mac (10.9.2) to Xcode 5.1 this week (gcc 4.2.1), and
> I have tried a total-start-from-scratch build of gnucash-git.  My woes with
> this:
> * ~/gtk/source/webkit-1.6.1/ is missing "-stdlibc=libstdc++"
> on line 120. (previously reported, and I know how to work around this).

Have you run since the last time? I fixed this in .jhbuildrc instead of the moduleset.

> * guile 1.8.8 hangs forever trying to create a texi file in libguile.  To
> reproduce, I can do by hand:
> $ pwd
> /Users/jaearick/gtk/source/guile-1.8.8/libguile
> $ cat *.doc | GUILE="/Users/jaearick/gtk/source/guile-1.8.8/pre-inst-guile"
> ../scripts/snarf-check-and-output-texi
> ERROR: Unbound variable: define  (hangs forever)
> ^C
> The problem lies in the snarf-check-and-output-texi script, but I have no
> idea what this does.  I tried to fake out this portion of the build by
> simply doing "cat *.doc > guile-procedures.texi", which will get the rest
> of guile to build, with a bogus texi file.

I've never seen this problem before, but I haven't done any builds since the Xcode upgrade. That could be a serious problem.

> * The build of gnucash-git did not like my fakery with guile, because it
> will then hang during the configure for gnucash:
> checking for GUILE... yes
> checking for guile... /Users/jaearick/gnucash-git/bin/guile
> checking for guile-config... /Users/jaearick/gnucash-git/bin/guile-config
> checking for guile-tools... /Users/jaearick/gnucash-git/bin/guile-tools
> checking if (www main) is available... (hangs forever)
> ^C*** Error during phase configure of gnucash-git: ########## Error running
> ./ && ./configure --prefix /Users/jaearick/gnucash-git --libdir
> '/Users/jaearick/gnucash-git/lib' --enable-ofx --enable-aqbanking
> --enable-binreloc --enable-dbi --with-html-engine="webkit"  *** [62/62]
> Any ideas please?

Without a clean Guile, Gnucash is hopeless, so you've got to get Guile to work without "fakery". Unfortunately Guile2 doesn't build clean either and I haven't taken time to work on that; filing a bug against Guile 1.8 isn't going to get us anywhere.

I've no doubt that the snarf-check... scheme program was revealing a problem in C; upgrading clang wouldn't have any effect on the scheme, it's going to affect the interpreter.

Try turning off optimization when building Guile, that's often the source of weird results. If it still hangs, add a debugging flag and run snarf-check... in the debugger and see why it's hanging.

John Ralls

More information about the gnucash-devel mailing list