Some Assistance Please

David T. sunfish62 at
Tue Apr 25 10:33:37 EDT 2017


Once again, the documentation bug has bit me, and I am trying to use the accepted GnuCash toolset to implement a change to the Guide. 

Most recently, this toolset has been changed to use “make”, and when I attempt to refresh my memory by going to the wiki page, I fail to find an explanation that makes sense to me.

My environment is as follows:

OS: Mac
Git clone saved in ~/Development/Gnucash/docs
Build directory in ~/Development/GnuCash/build

Specifically, if I have an already-existing installation of the downloaded documentation source that I have pushed and pulled into alignment with github, and I have finished editing the source files, what are the precise commands I need to invoke to get a tested and compiled local documentation set? 

Today, I used “make check” from ~/Development/Gnucash/docs/guide/C and all seemed to work; I got no errors following the actual xmllint command. When I changed over to ~/Development/GnuCash/build/guide/C and entered “make html” (per the wiki), I received an error:

configure: error: source directory already configured; run "make distclean" there first

I went to the docs folder and entered “make distclean” and got some output. I then returned to build/guide/C and tried again. I get the same error. No combination of make commands seems to move the process along.


P.S.: I continue to think that the wiki page is poorly-constructed for general users. In specific, I object to the high-level structure that embeds the initial setup steps with the ongoing editorial process. In my situation, I find it impossible to separate the setup commands from those that I actually need to proceed.

More information about the gnucash-devel mailing list