Some Assistance Please

Frank H. Ellenberger frank.h.ellenberger at
Wed Apr 26 07:11:22 EDT 2017


Am 25.04.2017 um 16:33 schrieb David T. via gnucash-devel:
> Hello,
> Once again, the documentation bug has bit me, and I am trying to use
> the accepted GnuCash toolset to implement a change to the Guide.
> Most recently, this toolset has been changed to use “make”, and when
> I attempt to refresh my memory by going to the wiki page, I fail to
> find an explanation that makes sense to me.
> My environment is as follows:
> OS: Mac Git clone saved in ~/Development/Gnucash/docs Build directory
> in ~/Development/GnuCash/build

Here I would use ~/Development/GnuCash/docs/build to avoid collisions,
when you later might checkout other projects like e.g.
With your structure after running the commands would be
cd ../build
../docs/configure ...
cd ../docs/guide/C/
cd ../build/guide/C/
make check
make html
[make install]

> upstream: origin:
> Specifically, if I have an already-existing installation of the
> downloaded documentation source that I have pushed and pulled into
> alignment with github, and I have finished editing the source files,
> what are the precise commands I need to invoke to get a tested and
> compiled local documentation set?
> Today, I used “make check” from ~/Development/Gnucash/docs/guide/C
> and all seemed to work; I got no errors following the actual xmllint
> command. When I changed over to ~/Development/GnuCash/build/guide/C
> and entered “make html” (per the wiki), I received an error:

Huh, and are in the source tree, but real
makefile(s) should only appear in your build tree. If I am in the source
tree, I get:

> make
make: *** No targets specified and no makefile found.  Stop.


> make check
make: *** No rule to make target 'check'.  Stop.

If you can run make in your source tree, then you once had run configure
without a build dir and should now clean your source tree.
See the help page of 'git clean' for details.

Your developement environment might have stored some project related
settings in hidden files in your source dir, which you do not want to loose.

> configure: error: source directory already configured; run "make
> distclean" there first
> I went to the docs folder and entered “make distclean” and got some
> output. I then returned to build/guide/C and tried again. I get the
> same error. No combination of make commands seems to move the process
> along.

“make distclean” is the counterpart of "make dist", which again will
finally create some compressed Tape ARchive.

> Thanks, David
> P.S.: I continue to think that the wiki page is poorly-constructed
> for general users. In specific, I object to the high-level structure
> that embeds the initial setup steps with the ongoing editorial
> process. In my situation, I find it impossible to separate the setup
> commands from those that I actually need to proceed.

The page was created by Tbullock, a documenter like you. Devs mostly
touched it, when changes happend like switch from svn to git. So feel
free to improve it.


More information about the gnucash-devel mailing list